Have a Buffalo wireless router running DD-WRT. It was working fine but suddenly today I can't get any internet through it. There is no internet connection if I connect via wireless or even the LAN port. This is what I see if I try to go to any website:

This webpage is not available
The server at www.baidu.com can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.
Here are some suggestions:
Reload this webpage later. […]

I've reset the modem, I've tried two different laptops and both have same problem in that they can't connect through the router. Any ideas?

P.S: the wireless adapter in each laptop is set to automatic DNS.


I have Internet if I connect directly to the FTTH modem. Also, another wireless router I have works.

  • Have you spoken with your ISP to ensure they're not having an outage in your area? How navigating by IP address, does that work? – Ƭᴇcʜιᴇ007 Nov 1 '11 at 19:49
  • i have internet if i connect directly to the ftth modem so its a router issue. Also another wireless router i have (free one) works. – Daniel Gratz Nov 1 '11 at 19:54
  • Then it sounds like your router is probably broken. Have you tried resetting it to factory defaults (if it allows this)? – Ƭᴇcʜιᴇ007 Nov 1 '11 at 19:59
  • Broken? It's only 1 day old... i did flash ddwrt onto it from the default firmware but it did work for a day... resetting to defaults didnt help. – Daniel Gratz Nov 1 '11 at 20:10
  • Well flash the factory firmware back on and try that. If you can't, then you probably now own a 'brick' (as you may have invalidated the warranty by replacing the firmware). How about a re-flash of DD-WRT? – Ƭᴇcʜιᴇ007 Nov 1 '11 at 20:16

First step in EVERY connection outage should be to bypass your router and connect your computer directly to your ISP device. Can you ping your DNS server? If the answer is no, try If that still doesn't work, call your ISP. If it does work, then ping google.com, does it work now? If no, change your DNS servers and retest. If yes, your internet connection is fine and it is something with your router (since you have already ruled out a single computer).

Plug your router back in and log into it. Do you get an IP? Is your DNS set correctly? Try the above tests again from the router interface. Check your DHCP configuration. What do your computers get when they type ipconfig or ifconfig? Does that match what your router is set to hand out? Have you tried swapping cables between the router and the modem?

tcpdump can also be a friend here, especially if you can run it on the router's WAN (not sure if ddwrt is capable of this or not). It would be helpful to see what the router is actually sending out. I could also help to see what is being sent between the router and a computer.

Basically, you need to work on narrowing down the problem to a specific point on your network or you can do all the resetting and reconfiguring you want and it is just stabs in the dark.

  • I think it is bricked. – Daniel Gratz Nov 1 '11 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.