7stacks by Alastria comes highly recommended for Windows 7. I've installed it on Windows 7 64 bit Ultimate. When I run 7Stacks, the cursor turns busy for maybe 10 seconds and nothing else ever happens. The task manager will show that 7Stacks is running in memory, but there's no user interface, no menus, etc. Does it work in 64bit? It's a 32 bit app.

UPDATE: 7Stacks seems to have a problem if your DPI setting is not the default 100%. The authors have been informed.


As an alternative, try Jumplist launcher. It looks like it may serve a similar function.


If it plugs into Windows in any way, via the Taskbar or Explorer and is not 64-Bit it will not work. The application needs to be compiled specifically for 64-Bit or must have dual support.

I have searched through the version history and the downloads and can't find any confirmation that it does indeed support 64-Bit, and I suspect because of the Explorer integration this would be the reason for the problem.

They do however have a contact us option on the site, and I have mailed them to ask if Stacks is supported on 64-Bit Windows. I will update once I receive a response.

  • the author of the software got back to me and says although it's a 32 bit app, it works fine under 64 bit Windows 7. I will post an update if I resolve the situation. – Knox Sep 4 '09 at 11:44

Author of software got back and said that the software worked fine under the RC but doesn't work with the RTM... He should have resolution before RTM is released (Oct 22 2009 if I remember correctly)


I've got 64-bit Home Premium store version and when I run it and set up a folder, it doesn't do anything, not so much as a button to add the folder to the taskbar, no cursor activity, nothing.

Oh well, sounded too good to be true..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.