I'm fixing an IBM Thinkpad laptop running XP Pro which doesn't boot all the way (It gets past the XP logo boot screen, a movable mouse cursor appears, and it doesn't get any further, even in safe mode) after being bumped a bit.

I'd like to do a repair install. I booted it to an XP Pro CD, but the Repair install option (not recovery console) doesn't appear.

After pressing F8 to accept the EULA, it says, Loading setupp.ini, then immediately goes to a partition list (it never says Searching for previous installations of Microsoft Windows). If I select the partition, it warns me that there is already a Windows installation in that partition, and that it will be completely obliterated if I continue. (So I know that it does see the contents of the hard disk)

I booted the same CD in an XP virtual machine, and it offered to repair the XP installtion in the virtual machine, so the problem isn't with the CD.

Does anyone know how make it do a repair install (or have any other ideas to solve the problem?)

It might not show up because it's an OEM installation (but not an OEM CD), but that's just a guess.

| improve this question | | | | |

XP's setup sees OEM, retail and volume CDs and installs as different and so does not offer the repair option.

If you copy the CD, altering the data in the setupp.ini file you can "create" a disk of the right type; there are some other differences between the disks, but I can't remember what they are - and in your case are probably irrelevant.

| improve this answer | | | | |
  • 1
    OEM vs Retail definitely matters, and is a pain to work with when doing a repair install. – Rob Nov 30 '11 at 4:56

The repair option should be on the same screen as the Parition list. Your assumption is correct though. If the install CD does not match the installed version, you will only get the install option, even if its XP Home versus XP Pro.

I'm not sure if Service Packs (installed SP2, but CD only has the original or SP1) will also affect that, but I suspect they do.

| improve this answer | | | | |
  • 1
    Both the CD and the HD are Pro. The only mismatch is that the HD is OEM, and the CD isn't. Should that matter? – SLaks Sep 3 '09 at 22:07
  • CD is SP2; HD I don't know (It's not mine), but is probably SP2 or SP3. – SLaks Sep 3 '09 at 22:09
  • However, the VM I tried it on (which did offer repair) is SP3. – SLaks Sep 3 '09 at 22:09
  • 5
    My suggestion would be to get a Linux Live CD and run NTFSFix as noted in Col's answer here: superuser.com/questions/30691/windows-xp-wont-start. If that doesn't work, boot into linux, back up any important files and do a complete reinstall. I would suggest the Ubuntu Live CD instead of Knoppix if you are new to Linux: ubuntu.com – Rob Allen Sep 3 '09 at 22:17
  • I think you can do a repair with a cd with ons sp on another... I have seen a computer with a mix of sp1 and sp2.. from that. don't remember the details which way round, It didn't work that well - IE was an IE of one sp(help..about), and msinfo32 said another SP. – barlop Dec 10 '10 at 6:41

I found myself in the same situation. I ended up going to the recovery console, and I ran chkdsk c: /r. It found some errors in a registry file, and after it repaired them, I was able to boot from my XP disc and see the Repair option.

After I ran the repair, it said Windows had not been activated, but it wouldn't bring up the activation dialog until I rebooted into Safe Mode, uninstalled IE8 from c:\windows\ie8\spuninst, and then rebooted one more time. The reason the activation dialog wouldn't come up was that the repair left IE in an unusable state with both IE6 and IE8 files. You may also need to remove IE7 from c:\windows\ie7\spuninst.

After all that, I was able to activate and then continue by installing all of the missing updates.

| improve this answer | | | | |

I booted using the Windows Update Anytime DVD, which gives the repair option. Managed to recover from an earlier checkpoint.

| improve this answer | | | | |

I managed to do my chkdsk from a win7 install disk. After messing around with XP for a while, I finally gave that a shot.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.