For the life of me, I can't understand why my Acer Aspire One netbook goes to sleep despite all settings telling it not to sleep:

  1. The netbook is explicitly told not to "put the computer to sleep" when AC power is plugged in:

enter image description here

And it is also told explicitly to do nothing when I close the lid:

enter image description here

So, why does it keep sleeping after several hours, when the lid is closed, but it is streaming Internet radio via IE9?

Is this a bug in Windows 7? A bug in the Acer Aspire One line of netbooks?

  • 2
    Have you checked the BIOS for hardware-level power settings? – Ƭᴇcʜιᴇ007 Nov 1 '11 at 21:01
  • @techie007 Yes. There is NOTHING there that even hints at hardware-level power settings... (it's a modern netbook). Regardless, isn't Windows 7 supposed to override the BIOS as far as power management is concerned? – ef2011 Nov 2 '11 at 3:24
  • 2
    The BIOS can always win when it comes to hardware control. :) – Ƭᴇcʜιᴇ007 Nov 2 '11 at 18:47
  • @techie007 In older PCs yes. But this one is a "modern" one... ;) – ef2011 Nov 3 '11 at 14:23

Found this info over on SevenForums.com:

Just discovered Samsung's Fast Boot software, which is enabled by default. It claims to "enable" the system to enter sleep mode regardless of the power settings

Based on that scenario I checked with Acer for similar utilities for the Aspire One netbooks, and low and behold they have a "Acer ePower Management Application".

So perhaps try disabling that (or better all) Acer utilities (via MSConfig or alike), and see how it behaves.

| improve this answer | |
  • 1
    Thank you for this tip! Sure enough I found hoards of crapware MSConfig's startup tab. I disabled the "Acer ePower Management Application" and now I am following to see whether this does the trick. I am accepting your answer, unless something different comes along. It's beyond me why a respectable manufacturer like ACER would sabotage its own products by including crapware that works against the design of the operating system they chose to pre-install... – ef2011 Nov 3 '11 at 14:22
  • How "respectable" Acer is is an area for debate. ;) Perhaps check out PCDecrapifier for your bloat-ware removal needs. :) – Ƭᴇcʜιᴇ007 Nov 3 '11 at 14:30
  • Bingo! I had the same issue on HP EliteBook, after stopping HP software's processes lid closing started working as expected. – Ivan G Jun 1 '15 at 17:07

Check your advanced power settings (the link is on the first screenshot you posted). Sometimes these can contradict what you set on the initial Edit Plan Settings screen!

Try the following:

Hard disk/Turn off hard disk after/Plugged in:
Never (change x minutes to 0 minutes)

Sleep/Sleep after/Plugged in:

Sleep/Hibernate after/Plugged in:

Power buttons and lid/Lid close action/Plugged in:
Do nothing

Multimedia settings/When sharing media/Plugged in:
Prevent idling to sleep

| improve this answer | |
  • Thanks +1. I verified that advanced power settings are as specified in your message. Any other ideas? – ef2011 Nov 2 '11 at 3:34

I'd check the Task Scheduler and see if there are any tasks that sleep the computer.

Open the Task Scheduler by clicking the Start button, clicking Control Panel, clicking System and Security, clicking Administrative Tools, and then double-clicking Task Scheduler.‌ If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

| improve this answer | |
  • Thanks +1. I think you are onto something. There are so many tasks in there, is there a way to export all of them in to a text or xml file so that I can examine them more comfortably? I know how to export each task individually to an XML file but this is too tedious. Is there a batch command that exports all? – ef2011 Nov 2 '11 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.