I've been utilizing Emacs at work for over a month now and have had a very pleasant experience so far. The launch time has traditionally been south of 5 seconds even with my admittedly non-optimized .emacs file.

But that all changed last Thursday. Something happened that caused the startup time to skyrocket to a frankly unbelievable 43 minutes. I wish I was kidding.

I have already tried launching Emacs without a config file. This yielded an approximately 7 minute or so start up time.

Googling has turned up several posts regarding Emacs being slow due to not being able to determine it's host's FQDN. To this end I have disconnected myself from my work's network (unplugging the ethernet cable itself and also disabling the adapter from the OS). This resulted in normal load times (sub 5 seconds).

This appears to be the source of the issue, but I have no idea where to begin looking to solve the problem itself.

Additional info: Windows 7 Professional 32bit running GNU Emacs 23.3.

Any idea where to begin on remedying this situation?

  • may be try latest version. I am not sure how you get 7 min startup time with out startup file. I few hundreds of lines in my init.el it takes around 5 sec.
    – kindahero
    Commented Nov 2, 2011 at 15:36
  • @kindahero I wish I knew. Mine was doing great until this past Thursday. I'm really hoping there are some Emacs gurus that will know how to resolve this situation on SuperUser. I also added the version of GNU Emacs I am using. Commented Nov 2, 2011 at 15:50
  • Can't you disable that FQDN search?
    – m0skit0
    Commented Nov 2, 2011 at 15:52
  • @RyanWersal okay few things. did you clean init.el.? you may might have done this, but to make sure., please backup the init file, and delete the whole .emacs.d folder and start it again. other thing might be checking latest alpha version. alpha.gnu.org/gnu/emacs/windows
    – kindahero
    Commented Nov 2, 2011 at 16:09
  • @kindahero I have tried deleting the entire .emacs.d folder and .emacs file as well as launching Emacs with -q. That yields the aforementioned 7 minute launch time. I have also tried the latest alpha and, regrettably, the symptoms persist. Commented Nov 2, 2011 at 16:25

1 Answer 1


One thing you might try is to put the host into the .../etc/hosts file (I forget where it is on Windows). If this solves the problem you might want to involve some local admin help. If not, then you might try filing a bug report explicitly requesting suggestions on how you might trace the problem on behalf of the developers. Actually, the latter sounds like a good thing to do even if the root problem is a local network issue.

  • Unfortunately I have already tried manipulating the hosts file to no avail. At this point, it looks likely there isn't a simple answer and working with the devs on a bug report is the proper way to go. Commented Nov 14, 2011 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .