26

Possible Duplicate:
How do I disable Aero Shake in Windows 7?

Sometimes, and I really don't know how to do it, when I grab an application in the window-bar and drag it around, as if I'm waving, then all other windows are minimized to the taskbar.

I have three questions:

  • how do I do this?
  • what's this feature called in Windows 7
  • how can I disable this Windows 7 feature?

I know I can undo it by hitting Ctrl+Shift+Winkey+M.

5
  • Mine doesn't seem to do it anyways? W7 Pro :o
    – HaydnWVN
    Nov 2 '11 at 15:54
  • 1
    How to disable it was asked and answered on SuperUser back in 2009.
    – JdeBP
    Nov 2 '11 at 18:25
  • @JdeBP - Indeed it is. Voting to close. (Why didn't you?)
    – Shinrai
    Nov 3 '11 at 14:14
  • 1
    Because three minus one is not zero.
    – JdeBP
    Nov 3 '11 at 14:22
  • 2
    Many people might not know that this feature is called “Aero Shake”—especially as the days when Aero was the new and popular thing to talk about have become history. I think this question is better than the one it is marked as a duplicate simply because it describes the issue in a way that one who doesn’t know the feature’s name can actually find it.
    – binki
    Jun 11 '18 at 21:33
32

This feature is called Shake. Just wiggle a window vigorously to minimize all other windows. You can also just release the click on the window, then click again and waggle to undo this.

Disabling Shake entirely requires a registry edit:

  1. Browse to the following key:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Explorer
    

    (the Explorer key may not be there by default, just create it)

  2. Make a 32-bit DWORD called "NoWindowMinimizingShortcuts".

  3. Set the value to 1.

6
  • I'd just add that personally I've done this by accident maybe once ever, so I don't see a need to disable it. It can come in handy.
    – Shinrai
    Nov 2 '11 at 15:49
  • 2
    Apparently I have a shaky hand sometimes. When I try it on purpose, I don't manage to do it. But by accident, it happens, say, once a week or so, much to my surprise and annoyance (I like my messy overlaid windows on my big screens).
    – Abel
    Nov 3 '11 at 12:51
  • 7
    In Windows 10 you need to create a 32-bit DWORD value called DisallowShaking in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced and set it to 1
    – ntv1000
    Aug 15 '15 at 15:07
  • 2
    @ntv1000 's comment applies to Windows 7 also.
    – ashnazg
    Mar 28 '18 at 13:52
  • 1
    This: click again and waggle to undo this, is worth one thousand upvotes! Nov 1 '18 at 17:26
9

It most certainly is a 'feature' of Windows 7 and it's called 'Aero Shake', more details can be found here: http://windows.microsoft.com/en-US/windows7/products/features/shake

And what you are describing is exactly how it works. Grab the title bar of any window, give it a shake and everything else drops to the task bar.

To disable Shake you'll need to use either the Group Policy editor or do some registry tweaking as outlined here:

http://www.askvg.com/how-to-disable-aero-shake-in-windows-7/

3
  • 1
    Didn't realize you could do this in gpedit, that's helpful.
    – Shinrai
    Nov 2 '11 at 15:57
  • Thanks, you both answered this thoroughly and it's good to know that GP editor can do this.
    – Abel
    Nov 3 '11 at 12:52
  • If you could quote or place the instructions directly in your answer, that’d improve the quality of this answer.
    – binki
    Jun 11 '18 at 21:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.