7

I am running Windows 7 64 bit Ultimate and using Cisco AnyConnect VPN 2.5.3041. As expected, Fast User Switching got disabled as soon as I installed the VPN software.

This FAQ from Cisco references how to enable Fast User Switching when their VPN product is installed:

A. Microsoft automatically disables Fast User Switching in Windows XP when a GINA.dll is specified in the registry. The Cisco VPN Client installs the CSgina.dll to implement the "Start Before Login" feature. If you need Fast User Switching, then disable the "Start Before Login" feature. Registered users can get more information in Cisco Bug ID CSCdu24073 (registered customers only) in Bug Toolkit.

My problem is that I have disabled this on the client, but fast user switching is still greyed out.

This article mentions a registry edit, however they key they mention, GinaDLL, does not exist at the WinLogon registry point.

Update:

This article from Cisco covering AnyConnect specifically gives a one liner:

AnyConnect is not compatible with fast user switching.

The only problem is I now I had found a workaround before the last reformat/reinstall, but I can't remember what exactly I did previously.

7
+50

Note how that FAQ mentions, with emphasis mine:

Microsoft automatically disables Fast User Switching in Windows XP when a GINA.dll is specified in the registry.

Which is why you have came to the suggestion:

This article mentions a registry edit, however they key they mention, GinaDLL, does not exist at the WinLogon registry point.

Luckily you are smart enough to not just simply create that entry, because let's see what Microsoft has to say about GINA, deep in the development center we find:

Note: GINA DLLs are ignored in Windows Vista.

Exactly, GINA is longer supported since Windows Vista. So, not the right way to go about this...


Now, if that software can disable Fast User Switching, we can do the opposite:

  1. Start the Group Policy Editor (Start -> Run ->gpedit.msc).

  2. Go to Computer Configuration -> Administrative Templates -> System -> Logon.

  3. Set “Hide entry points for fast user switching” to “Not Configured” or “Disabled”.

  4. Do a gpupdate /force to update the registry, add /boot if you wish to reboot and reload it.

If you don't have the group policy editor, you can:

  1. Launch a registry editor (Start -> Run -> regedit.exe)

  2. Go to HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\

  3. Delete HideFastUserSwitching.

  4. Optionally, reboot your system to reload the settings.

0
-1

After "unhiding Fast user switching" on windows 10 Pro (Many links on a search gives the solution on how to do it on Winws Seven or Vista), I had to run Services.msc and disable network Access Management Logon Module.

Though, disbling this service will make some NAM's functions unavailable.

Fast User switching works fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.