A couple of years ago it was not possible to boot from USB on every computer (where the BIOS doesn't support this). There was a tiny ISO image which allows for booting from a USB stick.

Now we have the same situation with software for virtual machines such as VMWare, Parallels Desktop and this ISO is useful again. I use Parallels Desktop 7 for Mac OS X which doesn't have an option to boot from USB or USB stick.

I have following real world situation: I have HDD with Linux installed. It is not like Live CD, it is already configured by me. I use it on my computer at work to boot environment I like and I use it at home to have same environment. Sometimes I work with Mac OS X and want to download something for my Linux (such as updates and new software) and configure something if I need.

I can't boot from it using Parallels Desktop or VMWare because BIOS in this VMs doesn't recognize my USB or it can't be attached before I run my VM.

Where can I find an ISO that would allow me to boot from a USB stick?

  • 1
    I don't understand why this question got downvoted. It closely matches to what I want: boot a VMware VM from a USB device. Since you cannot assign a USB device to a VM before it actually boots, you have a chicken-and-egg situation. – Jeroen Wiert Pluimers Nov 4 '11 at 13:09
  • @JeroenPluimers Because you can boot from an ISO directly, there is no need to boot from a virtual or real usb. The question is premised on a misunderstanding. – Paul Nov 4 '11 at 13:39
  • 2
    @Paul I don't get it: Booting from USB is different than booting from ISO, so booting from virtual/real USB is a need in the virtual world just as it was a need in the physical world a couple of years ago. – Jeroen Wiert Pluimers Nov 4 '11 at 16:56
  • @JeroenPluimers It is ok, the original question omitted the relevant portion of the question, where the user wanted a writable image - a portable boot environment. The question has been updated now, so my answer is now off topic. – Paul Nov 5 '11 at 4:34
  • 2
    I know about them well, thanks. I've asked clearly about booting from USB, not about booting from CD. Last VMs I know was Qemu & Bochs where I can boot from USB without problems. and I don't understand why it's difficult to boot from USB on modern hardware and software. – Eir Nym Nov 5 '11 at 16:11

Add a new Hard Disk to your VM and then select the option to use a physical disk. Afterwards just choose the disk that corresponds to the USB disk, you can even use the option to select individual partitions to deduce what is the actual # for your USB drive.

  • Thank you! I'll try it! Today I mostly use xhyve with same trick. – Eir Nym Jan 3 '16 at 14:53
  • 1
    You're welcome! I just ran into this need a few hours ago and that is what worked for me. Although it's not exactly what I wanted, what I was really after was USB emulation but this is close enough for now and works fine. Cheers. – ner0 Jan 3 '16 at 20:21
  • Can you boot from this as well? – Jeroen Wiert Pluimers Jan 16 '16 at 13:30
  • 1
    @JeroenWiertPluimers Yes, in fact that is the main purpose for me. – ner0 Jan 16 '16 at 17:17

Use the Plop boot manager:

  1. From the download page, download 5.0.13.zip
  2. Unzip the file
  3. Make your VM's virtual DVD/CD drive use plpbt.iso as the image
  4. Connect your USB drive to the VM's virtual hardware
  5. Boot your VM from the ISO
  6. In the boot screen select you want to boot from USB
  7. Continue the boot from USB
  • thanks. it copies my answer. But I'll approve yours. – Eir Nym Nov 4 '11 at 11:03
  • Oh sorry, I didn't read the link from your answer; just typed down what I found out yesterday myself. Please feel free to copy my answer to yours and I'll delete mine and upvote yours. – Jeroen Wiert Pluimers Nov 4 '11 at 11:12
  • 1
    @JeroenWiertPluimers I have tried this using this with parallels 8 on mac, with plop 5.0.13 and 5.0.14, with windows/linux vm's using cd as boot first. When I tell plop to load a usb device, it just hangs. I have also tried making a mv out of plop, same failure point. – demure Aug 13 '13 at 21:38
  • 1
    @JeroenWiertPluimers Parallels 9 seems to have fixed this issue. (Do you recommend deleting my first comment to prevent confusion?) – demure Aug 30 '13 at 1:50
  • 1
    @JeroenWiertPluimers, ner0 gives more elegant solution. – Eir Nym Jan 12 '16 at 13:04

I've found what I want! Google search string was "boot from iso old bios"


If you want a small image you should check out damn small linux, you can find some pretty detailed instructions here.

  • can I boot from this linux to any system on USB I want? – Eir Nym Nov 5 '11 at 8:28
  • As long as the system supports a boot from USB drive then this will work. I misunderstood your question, I think what you were looking for can be found in the answer you chose. Once you have the Plop boot manager working you can use whatever flavor of linux you would like, assuming I understood your question right this time. Another thing, if you decide you don't like damn small linux you can always check out puppy linux, they share a similar mantra. – John Nov 5 '11 at 13:31
  • VMWare and Parallels Desktop doesn't allow to boot from USB directly. VirtualBox allows with tricks. /me smiles. – Eir Nym Nov 5 '11 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.