I've noticed that my Chrome canvas doesn't work properly. For example, if I try to update this W3 school canvas sample (even without changing anything), it no longer renders properly (the red ball just disappears). This works fine in Firefox.

I've tried both the current version of Chrome (15.0.874.106m), as well as the beta version (16), and the same thing happens. It's not just this page, that I'm experiencing it on, but that's the easiest example to point to.

I'm using the 11.10 Catalyst drivers for my Crossfired HD5850's, if that matters.

What might be causing this problem, and how might I fix it?

  • It doesn't work for me as well, so maybe time to file a bug? – slhck Nov 3 '11 at 20:16
  • Oops, it indeed does not work on my work computer. So yeah, must be a bug. – Mike Pateras Nov 3 '11 at 20:20

Chrome's browser console shows the following error:

Refused to execute a JavaScript script. Source code of script found within request.

The reason it isn't working is because Chrome thinks it's a XSS (cross-site-scripting) attack.

  • Ah, that explains that. I still have other troubles with the canvas, sadly. Most notably getting the dart samples to work. That I know works on my work computer, but not the one I'm currently using. Same version of Chrome, no javascript errors. Any thoughts? – Mike Pateras Nov 3 '11 at 21:00
  • If it's using WebGL or something, that would explain it, since not all computers support WebGL. I can't really know unless I have a link to some of the other pages that aren't working. – Na7coldwater Nov 3 '11 at 21:02
  • Hmm... I tried a different version of the same sample, and that seems to be working. I'll just chalk it up to the sample I was using having a problem. Thank you for your help. – Mike Pateras Nov 3 '11 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.