The stock NIC on my MSI Big Bang Xpower is a Realtek PCIe GBE RTL8111DL adapter. The NIC is reporting a speed of 100.0 Mbps, but the manufacturer's website says it is a Gigabit controller.

I read the NIC will auto negotiate the connection speed to the highest availalbe. I have it connected to a D-Link 5 port DGS 2205, which is a Gigabit device. Since both devices are Gigabit, I would expect the NIC to connect using a Gigabit speed.

I have another computer connected to this switch, and that comptuer is reporting 1.0 Gbps. So I suspect a configuration problem with the first computer's NIC. All connections use Cat5e cable.

How can I configure this Gigabit NIC to connect at speeds of 1.0 Gbps?

enter image description here

  • Try a different patch cord. The one you are using may be sub standard. – Chris Nava Nov 4 '11 at 17:25
  • Check the cable, if you are using a Cat-5 cable it won't run at 1 Gbps. – user104156 Nov 4 '11 at 17:25
  • 1
    Switch the cables around. Maybe the one you're using for this machine has a problem. – Daniel Beck Nov 4 '11 at 18:01
  • @Daniel Beck, that was the fix! I reseated the connection using the same cable and it jumped from 100.0 Mbps to 1.0 Gbps! So it was a physical connection problem, not a configuration issue. I was also interested to learn the speeds jumped discretely like this. If you post your comment as an answer I'll close out this question. – steampowered Nov 4 '11 at 18:15
  • @JM. Glad that worked, and thanks for your offer. – Daniel Beck Nov 4 '11 at 18:25

You need to check the cables

  • There are cables and cables. Since you have two, switch them between the machines and see what happens
  • Sometimes there are problems with the cables not being plugged in properly (esp. if the "hook" doesn't work or is missing). While I'd expect no connection, check this anyway.

Try also switch the physical ports on the D-Link. Some don't support 1Gbps on every door. Also try to connect the MSI Board alone on that switch. You can also force the connection speed on Windows or Linux.

Last one, check if there is a firmware update for your motherboard and try to get another router/switch (from a neighbour or so) that supports Gigabit connections. Not mentioned the cable because it was already mentioned! :)

  • This switch does gigabit on all 5 ports. In addition, switching ports with the computer which is connected at 1.0 Gbps has no effect. The driver on the NIC adapters is the latest driver. – steampowered Nov 4 '11 at 17:59

its mainly due to the quality of the cable, you need to repatch the cable and change the port in switch to make it work, if it still doesnt work , uninstall the NIC drivers and reinstall with the latest drivers, reboot your device and connect it again, if it still persists change the ports of switch again to testify it, worked with me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.