I just created a new Thunderbird profile. Unfortunately Thunderbird only downloads recent messages. I need to get all my messages and subfolders. Any idea?

  • 1
    Worked for me out of the box when switching to offline mode. Only spam|junk|trash folders needed to be manually activated.
    – neverMind9
    Apr 16, 2019 at 17:24

4 Answers 4


Go to Tools/Options/General/Config Editor or in more recent versions Edit/Preferences/Advanced/General/Config Editor. This may vary between operating systems.

If presented with a

This might void your warranty!

dialog, click on the button "I'll be careful, I promise!".

Type folders_for_new in the filter box.

Look for an option called mail.check_all_imap_folders_for_new or on newer versions mail.server.default.check_all_folders_for_new.

Change this setting to true. This has the effect of not treating inbox as special, but all folders are "inbox", so all folders will be checked and downloaded.

If this key does not exist, then add it (right click / new) exactly as it is written above as a boolean preference. When you add the preference, you will be asked for the initial value. Choose true.

Next, in Account Settings/the account you are referring to/Synchronisation & Storage ensure that "Synchronise all messages locally regardless of age" and "Keep messages for this account on this computer" are selected.

  • @EchtEinfachTV "Keep messages.." won't achieve what the OP is after, if the key isn't present, it needs to be added.
    – Paul
    Apr 9, 2014 at 0:01

There should be a menu or button to "go offline"

In my current Thunderbird 17.0.2 (on Ubuntu 12.04), the button is at the lower-left corner of the whole application.

Clicking the button will start the download and if everything is configured correctly (i.e. has keep all messages regardless of age local) then that is what it will download

  • 4
    This is the key. Hitting the button in the bottom left corner will take you to offline mode and will give you the chance to force Thunderbird to download everything. Mar 14, 2013 at 22:41

You have to check a box called "Keep messages for this account on this computer". Have a look at this tutorial for keeping IMAP messages in Thunderbird.

[Account Settings[1]

  • This option is already set. The main issue is that it doesn't get subfolders. Nov 5, 2011 at 18:20
  • Have a look at the tutorial, they write about this, too.
    – Jens Erat
    Nov 5, 2011 at 18:22
  • I read that part as well. It seems that Thunderbird is not able to see subfolders. I am going to try with another mail client. Nov 5, 2011 at 19:34

In the list of your accounts in the main window, and right click on the account name and click the "Subscribe..." option. You will then see the list of (sub)folders on the server, check the ones you want. They will now be synced with everything else.

Not the answer you're looking for? Browse other questions tagged or ask your own question.