I replaced my RAM today. I replaced the old one with a 2 GB stick.

On the specs is says the RAM should be at 667 MHz. The new one is at 1066. It boots and it works well. But if I restart it, it exits Windows (like it normally does), and then it does not boot up again, until I shut it down from the power button and start it again.

2 Answers 2


Go into the BIOS and set all RAM speed, voltage, and timing settings to their defaults. Enable automatic detection for all RAM settings. See if that solves the problem.

If so, the problem was that one of those settings wasn't correct for your current RAM configuration. There are a lot of ways it can be incorrect. If you want me to work out the right settings for you, update your question with the full specifications (or model numbers) for every stick of RAM in your machine. (You need to pick the lowest speed all RAM modules can support at the same voltage.)

  • That is a problem. I tried to find where to set it in BIOS but I see no option to do it. I have the Phoenix bios. It doesn't have anything RAM, CPU or clock related.
    – Andrew
    Commented Nov 6, 2011 at 8:10
  • It may be worth replacing original RAM in case it is another problem that happened by coincidence.
    – BrianA
    Commented Nov 6, 2011 at 8:25
  • I tried the new one with and without the old one and still the same problem
    – Andrew
    Commented Nov 6, 2011 at 10:02
  • Bios: Phoenix v 1.03
    – Andrew
    Commented Nov 6, 2011 at 10:12
  • Better to tell old and new brand and name of DIMMs in any case Commented Nov 6, 2011 at 11:29
  1. First to do is a bios update which often fixes incompatibilities with CPUs and memory.
  2. Have you bought some special overclocking-modules? If so, probably you have to increase memory voltage for having a stable system. This should be noted somewhere on the packaging. As David already proposed, reset all other settings to defaults.
  3. If both is fine, remove one of the modules and restart your computer. Problem still persists? Also try swapping modules and banks. Just read you only wrote about one module?
  4. Have memtest running for some while. Everything's fine with your RAM?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .