I recently got a new notebook which came with Win7 preinstalled. I'm not a Windows guy (all Linuxes here) but I decided to keep it just in case. The problem is that the notebook came with a 5400rpm disk while I had a new one 7200rpm disk, so I decided to move the Win7 partition to the 7200rpm disk. I cloned the original partition to the new disk using Linux ntfsclone and I'm able to mount the cloned partition perfectly fine with Linux.

The problem is that the new partition doesn't seem to boot. I added a Win7 config option to GRUB2 the following way:

menuentry "Microsoft Windows 7 BIOS-MBR" {
    insmod part_msdos
    insmod ntfs
    insmod search_fs_uuid
    insmod ntldr     
    search --fs-uuid --no-floppy --set=root C6E6F7B2E6F7A0BB
    ntldr (${root})/bootmgr

My partitions:

[root@gamma ~]# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x85682941

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   168834035    84416986+   7  HPFS/NTFS/exFAT
/dev/sda2       168834036   295795730    63480847+   f  W95 Ext'd (LBA)
/dev/sda3       295804845   442590749    73392952+   b  W95 FAT32
/dev/sda4       442590750   625137344    91273297+   7  HPFS/NTFS/exFAT
/dev/sda5       168834099   207904115    19535008+  83  Linux
/dev/sda6       207904179   217671635     4883728+  82  Linux swap / Solaris
/dev/sda7       217671699   295795730    39062016   83  Linux

It seems that the booting stuff of Win7 got corrupted and I'm stuck having them back in place. I actually tried with some of the commands suggested here, but got no luck so far. Any kind of help greatly appreciated.

  • Did you get an NTDLR error when trying to boot windows? – patricks Nov 7 '11 at 10:41
  • 1
    Windows hasn't used NTLDR in its bootstrap process for almost five years now, oldskool. – JdeBP Nov 7 '11 at 11:16
  • The exact error I'm getting is: "an error occurred while attempting to read the boot configuration". File: \\Boot\BCD. Errno: 0xc0000225 – Fabio Varesano Nov 7 '11 at 11:25
  • JdeBP: You're right.. just had an Windows XP VM here with this error.. – patricks Nov 7 '11 at 13:01

Have you tried using the bootrec.exe related commands to rebuild the MBR? Maybe it is not an MBR related problem but it's worth a try. This may help: How to Use the Bootrec.exe Tool in Windows Recovery Environment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.