42

I am running VirtualBox on a dual-monitor Windows 7 x64 system. When I put a VM into full-screen mode it always appears full-screen on my primary monitor even though the VM window was on the secondary monitor. Is there a way to make it appear full-screen on the secondary monitor?

64

When you are in Full Screen mode in the view menu choose "Virtual Screen 1", "Use Host Screen 2"

While in fullscreen mode, press HostKey + Home to bring up the hidden menu. Select View -> "Virtual Screen 1" -> "Use Host Screen 2"

3
  • Really late to comment, but is it possible to make 'Host Screen 2' the default one?
    – Chethan S.
    Jun 15 '15 at 11:12
  • @ChethanS. That's done in windows settings.
    – Tim
    Mar 16 '16 at 23:00
  • So for some reason, this fix didn't work in Full Screen mode for me, but in Seamless mode (my normal mode), using the view menu with this fix did the trick. Thanks!
    – Tim S.
    Feb 8 '18 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.