I'm trying to use SSH from a bash shell (Ubuntu 11.10) to connect to my home university via a proxy at work.

When I use PuTTY in Windows from the same place, I can put in the proxy details in the proxy tab and it works. However, I can't get it to work from Ubuntu.

I configured Ubuntu to use the proxy system-wide with the network-proxy dialog in the system settings. However, SSH doesn't work - either it can't resolve the hostname or the connection just times out.

What am I doing wrong?

I can browse the internet (also HTTPS sites), and can also update my packages, but I cannot use SSH, FTP or anything else.

The proxy settings I'm using for PuTTY and in the network-proxy settings are:

proxy-name:8888 (same for all protocols)

To be honest, I don't know what kind of proxy that is.

  • 4
    Proxy is a very generic name for a middle man program at application level. I suggest you to edit your question and specify which kind of proxy you use with putty on windows. Is it a socks proxy or a http one? Probably adding a relevant screenshot with your proxy settings in putty will help understand your question better. – vtest Nov 10 '11 at 6:04

I think it is likely the proxy implementation in putty does a CONNECT through the proxy server. Not many proxies are configured to accept this type of connection, as it means that the proxy can be used to piggyback any type of connection, whereas normally a proxy server is deployed to control what is allowed out of the perimeter.

If this is the case, then I expect that corkscrew is what you are after. This makes the initial connection to the proxy and initiates the CONNECT. You then push the ssh connection over this "tunnel".

There is a description of how you can do it here. It is likely that corkscrew is in the repository of your distribution, so try that first before downloading.

  • +1. corkscrew is the tool for the job, and will work. – Sirex Nov 10 '11 at 11:21
  • And I can very much confirm that it also did the job for me - thanks a lot Paul! – nandaloo Nov 11 '11 at 4:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.