I want to buy a Samsung Chronos notebook and install Ubuntu alongside Windows.

Will there be any trouble with the hardware? I'd hope all the ports should work fine, keyboard special buttons, lights on the keyboard, the fast boot technology (wake from hibernation in a few seconds), etc.

  • I would, if they live-chat-support was working or if their mailing support included this model in available list(this is actually very weird). So, i'll hope to see some of their support online or wait until anyone here can help me
    – foxy
    Nov 10, 2011 at 10:59
  • The fast boot technology is apparently vendor specific, and has something to do with UEFI, so it probably will not work on linux. There's other ways to speed up boot however.
    – Journeyman Geek
    Nov 11, 2011 at 0:16
  • 1
    Well, their support answered that that machine is compatible with windows 7 only, so I guess they will never admit, even if linux will work fine there.
    – foxy
    Nov 15, 2011 at 15:17

12 Answers 12


The best buy one I have didn't come with fast boot or back light keyboard. Ubuntu 11.10 works great on it with one issue. The touch pad can not scroll. ElanTech touch pad in the Samsung works to move and click mouse but it doesn't scroll. i've been looking for a while how to fix the problem. if and When i come across it I will share with the world.

  • Touchpad issue has been fixed in Quantal.
    – naught101
    Oct 31, 2012 at 10:41

I've given up with Ubuntu on this computer. I've been through all the posts here and tried all the various suggestions with varying levels of success. I haven't noticed anybody talk about fan speeds...perhaps folks didn't notice how often the fan goes off compared to win7...see my comments below.

What works

  • Wireless

  • Intel graphics (you can use OpenGL and Compiz with this)

What doesn't work

  • CPU throttling?? This one nobody has talked about, but if anybody is reading this, let me know if your fan isn't constantly going off. I found that the CPU temperature seems to be idling around 60C. On Windows it is in the high 20s/low 30s for each core going up to a max in the 40s. I rarely hear the fan go off in Windows but on Ubuntu it goes on around every minute or so (when the CPU goes to 65, it then cools down to 60 and shuts off, then again the cycle continues)

  • Multitouch touch-pad UNLESS you upgrade to kernel 3.2 from the PPA. Even then it's buggy...tried a few of the tweaks posted here which made it almost usable but ended up losing right button. However, multitouch gestures in unity worked, which was pretty cool.

  • Radeon: Can't get this to work with any driver, open source or proprietary. Tried using Ubuntu package as well as ATI's installer (the latter caused X to fail to start). However, you can luckily disable it if you read up on vga_switcheroo.

  • Power: I tried passing parameters on boot-up (e.g. pcie_aspm=force), but did not help. Utilized powertop, plus juniper as well but could never get power below 28W consumption. Without the tweaks I get around 33W. Getting battery life around 2.5 hours whereas I'm getting 5.5 to 6 hours in Windows 7.


I ended up resorting to Windows 7. It's a decent OS, but I prefer Ubuntu and do all my work in Linux. I ended up running Ubuntu in VirtualBox which works really well except for one big problem: You can't get OpenGL forwarding to work. This means you can't use Compiz with the VM meaning you're forced to use Unity2D.

In linux, we can switch off either or both the intel HD and Radeon. On Windows, it always uses the Intel unless you tell the ATI Catalyst software to use the Radeon. However, you cannot use OpenGL with the Radeon because of some deficiency in their software (i.e. only DirectX apps work with Radeon, OpenGL always defaults to the Intel). The Intel HD graphics has a problem working with VirtualBox's OpenGL forwarding...and hence you have to resort Unity2D. You cannot exclusively use the Radeon as your graphics card!

Oh and Samsung has refused to publish a fix for this either as BIOS firmware path or an ATI Catalyst patch (though other companies with the same problem have).

I put Ubuntu on dual boot on a small partition. Will try again in the future with the hope patches fix these problems. Really regret this purchase...didn't think any of the parts on this machine would be so problematic :/

  • Great job with this summation; covered almost all of the bases. Wish you luck in the future :)
    – zackrspv
    Feb 1, 2012 at 22:26

I just bought the Samsung Series 7 Chronos at Best Buy too. As mentioned above, everything worked out of the box using Fedora 16, with three issues:

  1. Power consumption was bad. I found and followed these instructions and my power estimates with a full charge are about 4 hours and 30 minutes - I can live with that. I forgot to mention that I also run Jupiter power manager.

  2. Elan touchpad - it all "works" - 2 finger scroll, 2 and 3 finger clicks, etc., BUT I have to use my fingers almost flat on the pad, rather than the tips as I am accustomed to (and I did boot it to Windows and the pad worked fine there), so the driver is still an issue I think. Note the touchpad settings under "Mice" in Gnome 3 system settings appear and allow the sensitivity settings for the touchpad to be set, but they don't have enough affect.

  3. This machine does have the second ATI graphics card, but I tried to install the drivers and got an unbootable laptop - it would be nice to run the dedicated video, but I am using this as a work machine and don't need the advanced GPU really.

If someone can find improved touchpad drivers though that would be awesome.

  • The touchpad hardware is crap, I think - lots of reviews (using windows) have complained about it too. Not a software issue.
    – naught101
    Oct 31, 2012 at 10:43

Yesterday I bought the Best Buy version of the Samsung Chronos 7, model 700Z5B (on sale for $800+tax.) IMHO, the faster hard drive and graphics chip of the 700Z5A model are not worth the extra $300-400. This is particularly true for the graphics chip (see ATI problems mentioned below). Also, you could swap out the 5400 RPM drive for an SSD in the future.

I installed Ubuntu 11.10. It only took about an hour to get it installed and configured, and most things seems to work (even skype worked immediately, which surprised me -- on my thinkpad I had trouble getting the mic to work properly with skype).

Here's what I've noticed does not work so far:

  1. no scrolling with the touchpad (as mentioned above)
  2. compiz

Regarding item 2, this is really unfortunate, but may be a problem with 11.10 and might be resolved if I downgrade to 11.04.

So far, my limited experience with 11.10 is as follows:

I installed the compizconfig-settings-manager (mainly because I don't like the huge unity launcher bar and icons, and I want desktop cubes and other nice effects). Apparently, you are supposed to be able to change the behavior/size of the launcher with the Ubuntu Unity Plugin in the compizconfig-settings-manager. However, none of the changes I was making were having any effect. I found out the reason is because compiz is not even running! ..and probably it will not run in 11.10 on the ATI graphics-based laptops (like the Samsung Chronos), until updates are made.

When I try to (re)start compiz with the command

compiz --replace

I get some normal startup messages and then the error:

Compiz (opengl) - Fatal: glXCreateContext failed

So, compiz fails to start. I looked into this a bit more and found that this is a common problem people have been having on ATI-based laptops running 11.10. See following post for further discussion:


Overall, I am very pleased with ubuntu on this laptop. The screen seems huge (compared to my 13.3 1366x768), and the quad-core i7 processor (which shows up in the system monitor as 8 cpu's) is amazing. The harddrive and network performace, however, are just average and are the main bottlenecks of the system for everyday tasks (e.g. installing ubuntu over the network!) For my work, however, cpu speed is what matters.

  • thanks for valuable information, these are really great news. But 2 questions: 1. Did webcam work out-of-box (with Skype for example). 2. Any problems with WiFi (or do you use ethernet?)? Thanks again, big relief for me.
    – foxy
    Nov 28, 2011 at 10:11
  • 1
    1. Yes, webcam worked out-of-box. Skype worked immediately after I installed it - video, mic, speakers - everything works! 2. wifi works out-of-box. Signal is ok. I heard this wifi chip is mediocre, but seems fine to me. The only thing that disappoints me is the battery life, but that's because my expectations were built up by claims in reviews that you can get upwards of 6 or 7 hours. I get 3 even when barely using the system. Probably they're using windoze software which slows the system & preserves battery life. I'd love to hear if other ubuntu users are getting good battery life. Nov 29, 2011 at 10:18
  • 1
    Update on battery life: I have my chonos 7 set up for dual boot (even though using windoze makes me loathe computers). when I reboot into windows, it estimates 6hrs 42min battery remaining (at 98% capacity). When I reboot into ubuntu, the battery indicator estimates 2hrs 35min remaining. I realize the "Samsung optimized powerplan" software will make the battery last longer in windows, but I never imagined the difference could be so big... this is disappointing. Hopefully I can learn how to get better battery life on this machine with ubuntu. Nov 29, 2011 at 11:35
  • Update: After reading this post I decided to upgrade to the 3.2 kernel (by following the very simple instructions here) Now the command 'xinput list' shows that my touchpad is recognized as "ETPS/2 Elantech Touchpad" and, in System Settings, I can select the option for 2-finger scroling, which works. However the touchpad is very quirkey and I'll still use an external mouse. Feb 12, 2012 at 5:58
  • N.B. If you previously created a /etc/modprobe.d/psmouse file (with the proto=imps module option) in an attempt to get the touchpad working with kernel 3.0, be sure to remove that file when you upgrade to 3.2. It will prevent the 3.2 kernel module from loading properly. Feb 12, 2012 at 6:04

I am another happy Ubuntu 11.10 user with Samsung Series 7. Almost everything works out of the box, except for that mentioned above.

One annoying thing that was not mentioned in the previous posts is that the Windows+W key (or Meta+W) is not working to zoom out and show all windows. I used to use this a lot on my old ASUS netbook because it's a great way to switch between windows. I am sorely missing this shortcut.

Other than that, I'm quite happy!


I've had the Chronos 7 from Best Buy for a couple months now and though I would share my experiences.

As for video, I don't do much 3d and for what I do the Intel card works fine. So what I did was follow the instructions here, https://help.ubuntu.com/community/HybridGraphics. Basically I have it set to boot to enable the Intel, disable the ATI. With that my system works great. I get no notifications for the ATI drivers so I know it's actually working (you will still see the ATI card with a lspci, but it's not being detected as the driver).

As for battery life. I'm getting about 4-5 hours, and here is what I did. Follow the instructions, here http://crunchbanglinux.org/forums/topic/11954. That will set up pm-utils to set powersave options when unplugged. The only thing I changed was the brightness on the Chronos seems to be in percentages from 0 -100 so for battery I've got 20 and for AC I've got 90. I downloaded pm-util 1.4.1 from here, http://pm-utils.freedesktop.org/releases/pm-utils-1.4.1.tar.gz. I copied from the pm/power.d directory, harddrive, journal-commit, pcie_aspm, readahead and wireless to the /etc/pm/power.d directory.

With these tweaks and passing pcie_apsm=force to grub, I am getting 4-5 hours of battery life consistently. I'm pretty happy with that though I certainly would like more.


After upgrading to kernel 3.2 to get the touchpad working, running synclient FingerLow=3 and then synclient FingerHigh=8 made the touchpad usable. Attempting to fix wireless now... Broadcom doesn't seem to get along kernel 3.2 on Ubuntu.

  • Thanks so much, I had upgraded to the 3.3 kernel and it was working laying the whole pad of my finger. I wasn't sure that would work, but with your settings it is working almost as smoothly as my MacBook Pro trackpad.
    – rado
    Mar 17, 2012 at 5:39
  • Hrm, what version of synclient do you have? I have 1.6.2 (quantal), and it only allows me to use values of 0 or 1 for those variables...
    – naught101
    Oct 31, 2012 at 10:55

Wireless works now for me (kernel 3.2.1). Afterwards I downloaded the broadcast STA driver and installed it like described in the readme, but I had to replace line 388 in file src/wl/sys/wl_linux.c

.ndo_set_multicast_list = wl_set_multicast_list,


.ndo_set_rx_mode = wl_set_multicast_list,

The touchpad is also working for me, but if I try to mark text or resize a window it's a little bit complicated, because the mouse bottons are recognized as touchpad.

Also the power management won't work, just 1.5h.


ElanTech touch pad

If you install gsynaptics, it will allow you to set your touchpad sensitivity. Setting this to max was doing the trick on my Opensuse 12.1 installation

If your touch pad is recognized, you should see this:

dmesg | grep elan

[ 1.373931] elantech: assuming hardware version 4 (with firmware version 0x361f06)

[ 1.414390] elantech: Synaptics capabilities query result 0x21, 0x15, 0x0f.


The problem is definitely the Linux driver with regard to the wifi. I've just compared wifi connection under Windows and Ubuntu 11.10 and the latter is quite bad. Perhaps it just needs the right Broadcom driver setup, but it's quite cumbersome to figure this out.


WIFI: I have to confirm the bad if not lousy wifi reception. This must be the driver (OpenSUSE 12.1 installation with driver: brmsmac) because under windows or with my old Samsung X20 sitting right next to the Chronos I have perfect reception. A solution for this is badly needed.

And the solution is: instead of brcmsmac use driver wl (package: broadcom-wl-kmp-desktop (I use the kernel "kernel-desktop" on my laptop, as selected by opensuse). I have now good reception.

  • If you're unhappy w/ the wifi you can purchase and install this card: amzn.to/MYa1Ko includes bluetooth and it's under $30 ... worht it! Jun 10, 2012 at 7:33

I just got this laptop. I got everything working with 11.10 except the wireless driver would crash my wireless router (buffalo with dd-wrt). I forced a kernel upgrade with "sudo apt-get dist-upgrade" and that solved the problem.

It appears the proprietary AMD/ATI drivers do not work yet. Luckily I still seem to get 2D acceleration with the integrated intel card and can run compiz, meaning I can run Unity instead of Unity2D. I tried installing the ATI driver through Ubuntu, then manually using ATI's package. The latter broke my installation and I had to reinstall. 2d acceleration is fine by me for now until Canonical updates the proprietary driver.

The mouse is problematic. No middle mouse button makes unity a pain and the thing gets in the way when typing. Also, the battery issue is killer. on the box it says 9 hours, on windows it says 6.5 hours, on ubuntu it says 2.5 hours! For a 9 cell battery, that's lame...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .