7

I'm using Xubuntu 11.10, but can't see how to disable the login screen. I'm pretty sure I set it to auto login during setup, but recently upgraded, and now it's asking for a password when I turn the machine on. Also, I've disabled "prompt for password on resume" but the password is still showing. Any ideas how to disable both of those passwords?

8

I feel your pain. 11.04 did have an easily accessible auto login setting. 11.10 took that away. To set autologin now you must edit lightdm.conf. In terminal at the user prompt type...

~$ sudo leafpad /etc/lightdm/lightdm.conf

Add the following line to the end and save...

autologin-user=YourDesiredAutoLoginUserName

To remove password on resume, right-click the system tray power icon then Preferences. This brings up the XFCE power manager (Alternatively you can navigate to XFCE/Settings/Settings Manager/Power Manager). Click Extended in the left pane. Uncheck Lock screen when going for suspend/hibernate.

The last place is XFCE/System/Users and Groups. If it's set "Password: Asked on login" you can change that but it's really not necessary.

  • 1
    I'm in Xfce 4.10 but did all that and still I'm asked for username and password after logging out... – user162573 Feb 8 '13 at 15:26
  • 2
    Make sure you do this under the [SeatDefaults] section ;) – user249232 Aug 28 '13 at 13:23
  • I desperately needed this answer!! – 7_R3X May 19 '18 at 18:23
2

To enable Auto Login:

  • Add autologin-user=YourDesiredAutoLoginUserName to /etc/lightdm/lightdm.conf

Disable Prompt for Password on Resume:

  • Uncheck 'Screen Locker' from Session and Startup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.