When I open Terminal I expect it to show what my PS1 is set to \h:\W \u\$.

However it's not displaying my hostname Eriks-MacBook, as displayed in System Preferences.

Instead, it's showing a random string unknownb88d120cd4b2.

How can this be fixed or reset?

This machine is brand new, and the preferences/settings haven't been changed.

  • Type in hostname into the prompt and press enter. What do you get? – Blender Nov 14 '11 at 4:27
  • unknownb88d120cd4b2:~ erik$ hostname unknownb88d120cd4b2 unknownb88d120cd4b2:~ erik$ – Erik W Nov 14 '11 at 4:43
  • But that is not what my computer's name is in System Prefs - Sharing. I changed it from default to "erik-mba" hoping that would help, but no dice. – Erik W Nov 14 '11 at 4:45
  • See also apple.stackexchange.com/questions/30552/… – rogerdpack Dec 19 '14 at 19:50

Gordon gives a good answer to the origin of your hostname.

If you want the name that you set in System Preferences -> Sharing -> Computer Name to show up in your prompt, replace \h with $(scutil --get ComputerName). E.g my prompt is set with

PS1="[\u@:$(scutil --get ComputerName) \W]\\$ "

Terminal is showing you the first label of your BSD hostname (assuming your shell is BASH). If your BSD hostname is yourhostname.mynetwork.com then Terminal will display only yourhostname-

So from where does the BSD hostname come? It can come from several places:

• from the file: /etc/hostconfig

• else from the file: /Library/Preferences/SystemConfiguration/preferences.plist (System ▸ System ▸ HostName)

• else the result of a reverse DNS query for your primary IP address (so you might notice a totally different hostname showing up when you visit an internet café than when connected at home)

• else your "Bonjour" hostname in System Preferences > Sharing (preferences.plist again... System ▸ Network ▸ HostNames ▸ LocalHostName)

• finally, if none of the above have been set, the BSD hostname will be simply localhost

By the way, I answered the same question a while ago over here: Mac OS X Terminal - where does the prompt name come from

  • 2
    is it possible that the reverse DNS lookup takes precedency over all other configurations on my system? – caesarsol Nov 27 '14 at 13:30
  • 1
    I checked on my own system: /etc/hostconfig does not exist. preferences.plist ▸ System ▸ System ▸ HostName is not defined (although ComputerName is). Reverse DNS lookup returns the gibbering I'm seeing in my terminal window. System ▸ Network ▸ HostNames ▸ LocalHostName is defined. So if your system is showing the same as mine, then the reverse DNS lookup was the first match, and does take precedence over LocalHostName. – Edward Falk Apr 25 '16 at 21:48

OS X tries a number of things to find its "hostname". Unfortunately I don't know the exact list (and order), but I think what's happening here is that it's discovering a DNS name associated with its IP address, and using that instead of the Bonjour name it's advertising for itself (the one defined in Sharing preferences).

So why's it finding a DNS name? My guess is that your local router/DHCP server/DNS server is dynamically assigning it one, based on its ethernet hardware address (presumably b8:8d:12:0c:d4:b2). You may be able to adjust the router's settings to stop it doing this, or you could probably set the computer's DHCP client ID (in the Network Preferences, Advanced settings) to control what name it assigns you.

  • 2
    This was most helpful to me. My machine was displaying this behavior, the key point being, to it seemed to have SPONTANEOUSLY changed names, as I had never seen a different one before. So I just wasted 90 minutes checking for viruses and disk issues and such. Glad to know I can safely stop wasting time. – conspiritech Mar 22 '13 at 18:18

Not sure if you are still having problems or not, this appears to have been fixed sometime between Yosemite and Sierra.

For new computers I start with the Sharing System Preferences, entering the [new name] as the Computer Name desired. I also enter the [new name] in all of the active DHCP Client ID fields for each network interface. After I've done that I open Terminal to confirm it reports a similar name, some characters are not allowed so the system will modify the name if necessary. You can change the name using the steps below, just replace the [new name] block with your desired computer name.

  1. Open Terminal
  2. At the prompt enter the following- sudo scutil --set HostName [new name]
  3. Open a new Terminal window to confirm the new name was accepted.

If the name is not to my liking I proceed with the above before binding it to Active Domain.


For me:

  • scutil --get HostName was empty,
  • /etc/hosts was fine,
  • /etc/hostconfig didn't exist,
  • the Bonjour name was right,
  • all the preference files were right, but hostname would stubbornly use a default name (iMac in my case).

Turns out the bad name was associated with the DHCP lease on the ethernet interface (but not the WiFi interface). To convince the DHCP lease to use the new name, I had to:

  1. Go to System Preferences --> Network --> Ethernet and change the "Configure IPv4" drop down to "Off".
  2. Click "Apply".
  3. Click "Advanced", then select the WINS tab.
  4. Change the NetBIOS Name (which showed the old name) to the new name.
  5. Click "OK", then "Apply".
  6. Finally, change "Off" back to "Using DHCP".

Once the new lease was established, but the router and the local machine reported the new name and there was no sign of the old any more.

A bad DHCP lease was definitely the culprit, but fixing the NetBIOS Name before renewing the lease might have been the clincher.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.