I've tried to install OpenWRT Backfire 10.03.1-rc6 x86_generic combined ext2 on my x86 PC, but the boot process stops while "waiting for root device /dev/sda2".

Forums have advised me to build a custom OpenWRT image, but I don't know what packages I should include to solve this problem.

I've tried adding kmod-ata-via-sata but it doesn't help.

3 Answers 3


I ran into this problem before. I had to build a custom image from source to solve it. The cause was that the disk controller driver wasn't included in the kernel. Without the driver, the kernel couldn't access the root partition and became stuck.

To add this driver I had to compile from source. I added the driver using make kernel_menuconfig. I also ran make menuconfig and disabled the matching kmod-* kernel module. I took these steps when I realized kmod-* kernel modules were stored in the root partition, not compiled into the kernel.

Must you use a SATA hard drive as the storage device? How about using live USB instead? I worked out a method to store many disk images on a flash drive. The step-by-step instruction is at my blog http://macbruins.wordpress.com/2011/09/01/easy-live-usb-for-x86-openwrt.

  • Can you tell me how to add the driver in kernel_menuconfig ?
    – Euphorbium
    Nov 18, 2011 at 10:27

I'm not positive, but I believe that OpenWRT is intended to be installed on a router. It enables your router to do things that it may not have been able to do before switching the firmwares. I don't think it is intended to be installed on a computer.

  • 2
    It's not entirely impossible. A router is a computer, just with slightly different hardware.
    – slhck
    Nov 14, 2011 at 21:17
  • It should be possible - there are builds for x86, and this guy has managed to boot it from usb flash drive. I would use his method, but I want to install openwrt to internal hard drive.
    – Euphorbium
    Nov 14, 2011 at 21:31

I think the most likely reason is the openwrt build you are using doesn't have a kernel module for some part of the disk system you are using - most likely the sata disk controller.

One approach would be to get a linux liveCD, boot it up on the PC, confirming it can see the disks, then do an lsmod to see what disk related modules were loaded.

Then see if those modules are available as kmods for openwrt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.