24

I'd like to disable ctrl+alt+arrow keys changing the screen orientation. I've seen here that this is a function of the Intel graphics driver. So I followed the directions and disabled hotkeys in the Intel graphics card control panel, but the hotkeys are still enabled. Might there be some other program controlling this? I'm running a Lenovo T420.

  • 7
    I'm right there with you. This hotkey should never be enabled by default-- it causes way more problems than it solves-- who needs to rotate the orientation of their screen on a regular basis? It should be kept some control panel dialog. – Conrad.Dean Nov 18 '11 at 22:15
  • +1 for ctrl+alt+arrow keys...this is nice shortcut key!! – AminM Apr 10 '14 at 10:56
  • 3
    A better answer to this question is at this linked question. – 6005 Jan 2 '16 at 3:38
6

Besides disabling the feature in the Intel driver you also need to uninstall the Lenovo Screen Reading Optimizer.

  • that did the trick! – Eran Medan Aug 28 '12 at 22:17
4

[HKEY_CURRENT_USER\Software\INTEL\DISPLAY\IGFXCUI\HotKeys] "Enable"=dword:00000000

Setting this registry key will do what you want.

  • didn't work for me, the enabled was already set to 0, possibly due to the configuration in the software – Yurik Sep 30 '14 at 6:42
  • This is a good way to programmatically disable this by setting this key in registry. – zar Aug 10 '17 at 14:18
4

As anyone that does even the mildest amount of programming will attest, it is very frustrating having 3rd party overriding the keys and sending you on a wild goose-chase for why disabling is not enough.

the thing is that even if you disable the hotkey functions, the key presses are still trapped and do not "bubble" to your application.

a quick fix is to enable hotkeys, assign them to different keys. I've used Ctrl+alt+F2, F3, F4, F5 and then disabled.

I'll have to see what functionality that will break...

this is not the best solution, but I think the fastest to implement and easiest to revert.

3

I see several people referred to the Intel HD graphics driver, but without much in the way of instructions, so perhaps this will help. (Note, this response is partly based on this answer: https://superuser.com/a/592688/197972).

On my system (Windows 10, Intel HD Graphics 5500, driver version 10.18.15.4281, dated 8/31/2015), the answer is:

1: Launch the Intel HD Graphics Control Panel (it's on the start menu).

2: Click the icon labeled "Options and Support":

Intel HD Graphics Control Panel

3: Under the "Manage Hot Keys" section, click "Disable":

Options And Support

4: Click "Apply" to save the changes.

  • 2
    This only disables the functionality. The hotkeys are still intercepted and can't be used. Since these are important defaults in IntelliJ it's quite annoying – Shanteva Jun 22 '17 at 15:11
  • According to a thread on Intel's forum (communities.intel.com/thread/51399) it was reported fixed in March 2015. It might be worth checking to see if there's an update you can try. – David C. Jun 23 '17 at 17:09
  • So, the link from that thread is gone, but I did find the latest drivers, but they refuse to install on my system, probably because they have to be HP's version. Anyway, this does not solve the problem for me. – Shanteva Jun 23 '17 at 17:19
2

After disabling these keys, I find that they sometimes remain in effect until after the system is rebooted. Here are two possible solutions:

  • Try rebooting the system
  • Try updating the video driver

If neither of those work, then you can use SpyBot's "System Startup" editor feature to disable the function keys StartUp module:

  SpyBot - Search & Destroy
  http://security.kolla.de/

  1. Make sure "Advanced" mode is enabled (under the "Mode" menu)
  2. Select the "Tools" category (only available in Advanced mode)
  3. Select the "System Startup" option
  4. Find the tool called "hkcmd" and disable it (this is Intel's hot key manager module)
1

Another option is to disable the Intel(R) HD Graphics Control Panel Service altogether. Or don't have it be started automatically.

See more info here.

0

Steps 1-Move the mouse to the screen & right click (you will see View, Sort by, Refresh, Graphics Properties...point to Graphics Options & Select Hot Keys. 2-Select Disable. 3-Now if you try to press [Ctrl] [Alt] + Arrow Keys the video screen wont rotate any more. For some reason you want to control screen rotation just Enable it again.

  • The question states that this had already been tried. – Chenmunka Jan 29 '16 at 12:56
-1

"hkcmd.exe" is Intel's "extreme" grahics hot key interceptor. If you never use the Intel hotkeys, you can go to Control Panel > Intel Extreme Graphics > Hot Keys and turn them off.

Get more detailed information about hkcmd.exe and all other running background processes with Security Task Manager.

Source: http://www.neuber.com/taskmanager/process/hkcmd.exe.html

Good luck!

  • You should quote the relevant information from your link. – Ramhound Jun 30 '16 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.