I'm running an install of CentOS 5.5 virtually and for some reason I only have 2 available screen resolutions - 800x600 and 640x480. Does anybody know how I can add some bigger resolutions?

I've had a look in /etc/X11/xorg.conf and it is knows that the graphics card is virtual, but even listing the resolutions that I want fails.

Here is the default screen section -

Secton "Screen"
        Identifiew "Screen0"
        Device     "Videocard0"
        DefaultDepth    24
        SubSection "Display"
                Viewport 0 0
                Depth    24

And here is what I tried adding to SubSection "Display" -

Mode "1024x768" "1280x1024"

Look at Xorg log file. You should see there usually list of resolutions your graphics card and monitor supports. I'm not sure about this CentOS version but usually you can use xrandr to change resolution on fly if RANDR extension is loaded (look at xdpyinfo output)

| improve this answer | |
  • Thanks for the reply, Cougar. I've just discovered xrandr --newmode <modeline>, but the modeline I created using CVT didn't work - it just displays the help for xrandr. – David Gard Nov 18 '11 at 10:11
  • How does your modeline look like? If xrandr displays a help then it has problems with your modeline syntax. Did you put "" or '' around your modeline string? – Cougar Nov 18 '11 at 16:35

Not sure where the configuration files are, but I go into "System » Administration » Display" menu option, choose the Hardware tab and the click the "Monitor Type Configure" button.

This gives me the option to choose between CRT or LCD Displays, on both laptops and desk computers I choose CRT and click on the RIGHT ARROW (clicking on the text merely highlights it) this should allow multiple resolution choices. Once chosen go back to the settings tab, which should now allow more choice and choose accordingly.

I've set this on many systems but even after doing so and searching for recently modified files I've failed to nail down which file contains the new settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.