Ctrl+Shift+U is a combined shortcut in Eclipse.

But when I press it, it shows up a u, just like input with an underline. I guess this shortcut has been declared by Ubuntu, so I can't use it.

I used to solve this problem by typing Caps Lock first.

Is there any better method?

  • @Code-Guru: (1) You might have Locate Pointer setting turned on in Universal Access under Pointing & Clicking section. Turn it off to see if it works. (2) This answer below is claimed by some as still working.
    – harrymc
    Commented Nov 18, 2020 at 20:57
  • 1
    For reference, this causes conflicts with IntelliJ as well. More details: youtrack.jetbrains.com/issue/IDEA-112533/… Commented May 11, 2023 at 20:30
  • More universal solution with additional details here is to rebind this hotkey to Ctrl + Super + Shift + u Commented Apr 15 at 14:46

12 Answers 12


Found a way to unbind it on Ubuntu 13.10.

Go to Language Support on System Settings and change the Keyboard input method system to none

Then restart the system or just log out and log in.

  • 13
    Just logging out and back in works for me.
    – Martin
    Commented Apr 29, 2014 at 10:13


The problem is that with the "Ibus" input method, "Ctrl-shift-u" is by default configured to the "Unicode Code Point" shortcut. You can try this: Type ctrl-shift-u, then an (underlined) u appears. If you then type a unicode code point number in hex (e.g. 21, the ASCII/unicode CP for !) and press enter, it is replaced with the corresponding character.

Example of ctr-shift-u

Solution (GUI)

This shortcut can be changed or disabled using the ibus-setup utility:

  1. Run ibus-setup from the terminal (or open IBus Preferences).
  2. Go to “Emoji”.
  3. Next to “Unicode code point:”, click on the three dots (i.e. ...).
  4. In the dialog, click “Delete”, then “OK”.
  5. Close the IBus Preferences window.

Ibus preferences window

Solution (CLI)

If you want to script this, the Unicode hotkey can also be disabled using gsettings like this:

gsettings set org.freedesktop.ibus.panel.emoji unicode-hotkey "@as []"
  • 1
    @Phill Indeed, for me, too, this no longer works. Even though it clearly should. It doesn’t seem to work in either 19.10 or 20.04, unfortunately. Commented Apr 7, 2020 at 14:59
  • 1
    @kleinfreund I figured out a way by renaming the IBUS daemon mv /bin/ibus-daemon /bin/ibus-daemon.bak and rebooting. This killed it for me finally.
    – Phill
    Commented Apr 8, 2020 at 6:20
  • 2
    Ubuntu 18.04.4 ibus-setup has emoji shortcuts, but no unicode chortcuts settings : (
    – yurenchen
    Commented May 9, 2020 at 10:58
  • @Neurotransmitter For me, these steps unfortunately no longer work. I also tried to set the keyboard input method system to “none”, but the two shortcuts are still active when I type in, for example, a VS Code editor window. Commented Sep 4, 2020 at 6:39
  • 1
    Tried again this solution and it worked. It seems that the linked patch was required to make the solution work bugs.launchpad.net/ubuntu/+source/ibus/+bug/1885914
    – Greg Dan
    Commented Oct 1, 2020 at 14:27

Ubuntu 18.04 Solution

@ShmulikA's answer was close, but unfortunately, selecting "None" did not work for me. I can confirm the process below works in 18.04 as of April 2019.

  1. Open Search using Super key (aka WIN for folks like me)
  2. Type "language support" and hit ENTER

enter image description here

  1. Click the Keyboard input method system dropdown menu and select XIM

enter image description here

  1. Click Close
  2. Reboot

When I logged back in, I was able to set CTRL+SHIFT+U as a shortcut in Visual Studio Code.

  • 3
    This unlocks the key binding but messes up some applications. Dconf Editor is very glitchy now and DBeaver became unusable. How hard can it be to disable a fraking shortcut, Ubuntu?
    – Rafał G.
    Commented Oct 1, 2019 at 7:58
  • 2
    After changing the input method, gedit and other gnome text fields had "transparent" background bug. To fix that execute rm ~/.xinputrc and reboot. Solution from askubuntu.com/a/840073/28004
    – Greg Dan
    Commented Mar 17, 2020 at 10:22
  • 3
    @Brown I just found out that after removing the .xinputrc file the ctrl+shift+u doesn't work again. I am trying other solutions, however without success so far.
    – Greg Dan
    Commented Mar 18, 2020 at 19:51
  • 1
    I have continued VERY bad experiences with setting xim under Ubuntu 16, 20 and 22 (among other thing an ever flickering LibreOffice). I don't have a sound explanation, but returning to IBus (which is the installation default) fixed that.
    – Frank N
    Commented Dec 26, 2022 at 12:13

I use Ubuntu 18.10 and had trouble in a particular app (Intellij Idea).

In this askUbuntu answer, Kayvan Tehrani shows a setting that works for me in that setting. Set the XMODIFIERS to an empty string before running your application:

export XMODIFIERS=""

In my case, myapp.sh was idea.sh, and I added the line inside the file:

# ---------------------------------------------------------------------
# IntelliJ IDEA startup script.
# ---------------------------------------------------------------------
export XMODIFIERS=""

This way, my desktop shortcut still works.

XMODIFIERS apparently changes the way xim and ibus works, and when it's cleared, it disables the CTRL-SHIFT-U combo, allowing it to filter into the current app.

  • 1
    Helpful, but with the caveat that it also disables the compose key and any .XCompose shortcuts you might have set up (at least on Linux Mint 19.3---YMMV).
    – Kev
    Commented Jul 7, 2021 at 6:36


export GTK_IM_MODULE="gtk-im-context-simple"

and then run Eclipse from the same shell. Or if that doesn't work,

export GTK_IM_MODULE="xim"

(This test only works entering running the export command and then Eclipse from the same shell command line, it won't change anything if you use a desktop shortcut or the Applications menu, or run Eclipse from a new shell.)

If either test works, you can make the change system-wide by adding it to /etc/environment, or per-user in ~/.gnomerc. (The export command doesn't go in those files, just a new line with GTK_IM_MODULE="xim" or GTK_IM_MODULE="gtk-im-context-simple".)

It sounds like this behavior comes from GTK's input mappings as described here.

... This is called preediting, and an input method may provide feedback about this process by displaying the intermediate composition states as preedit text. For instance, the default GTK+ input method implements the input of arbitrary Unicode code points by holding down the Control and Shift keys and then typing “U” followed by the hexadecimal digits of the code point. When releasing the Control and Shift keys, preediting ends and the character is inserted as text. Ctrl+Shift+u20AC for example results in the € sign.

GTK is used by a whole lot of common apps in Ubuntu, including Eclipse.


Changing the input method as PutzKipa explains actually fixes the problem.

However, I've failed to find any configuration panel under KDE ubuntu 14.04 to do the job, and the standard im-config utility seems broken. I finally succeeded by creating a file ~/.xinputrc that contains a single line:

run_im xim

then logout/login. This chooses xim as the input method (ibus is the default). If you remove your ~/.xinputrc, then im-config can list the input methods available, even if it fails to select one.


Ubuntu 18.04

Running into this problem on Ubuntu 18.04, I've tried all suggestion above, but unfortunately none of them worked. I ended up uninstalling the ibus package.

Background / sidenotes

I tried to disable IBus using

  1. the Language Support menu
  2. im-config (configures ~/.xinputrc)
  3. sudo im-config (configures /etc/X11/xinit/xinputrc)

I noticed however that no matter what config I tried, the ibus daemon was running everytime after I had rebooted.


Ubuntu 14.04/18.04 Solution

Recently upgrade to 18.04 and fight my way to solve this issue.

  1. Open search using super key

  2. Go to language support

  3. Click Keyboard input method system dropdown menu and choose none

    Language Support Menu

  4. Don't forget to click - apply system-wide

  5. Close the window (won't activate until you do)

  6. Reboot (logout might be enough)

Credit goes to reverse issue on askubuntu - for some reason someone wants to enable this shortcut.


For Ubuntu 18.04

I struggled with this problem for two days. I tried all the methods listed here earlier. And it looks like I came up with a solution. But it is very unstable and has bugs.

The basic idea is this: in the system settings, you can specify the command that is started by the Ctrl+Shift+U key combination.

Note: if you specify false as the command, the combination will not work at all.

However, we can specify the path to the script as the command, in which we will simulate pressing the same key combination.

To simulate keystrokes, I tried the xdotool (apt install xdotool) and the xte (apt install xautomation). Both options were unstable. However, xte turned out to be more flexible for me.

Example with xte

  • Create a file /home/username/shortcut.sh
  • Add permission to execute: chmod u+x /home/username/shortcut.sh
  • Specify the path to the script as a command for the Ctrl+Shift+U key combination in the keyboard settings

Here is an example script:

# Make a small delay in order to have time to release the keys.
sleep 0.2

# Simulate the release of just pressed keys, if they are still pressed.
xte 'keyup u' 'keyup Shift_L' 'keyup Control_L'

# Hack: Caps_Lock is used so that the system does not intercept this combination.
# You can try to remove it if it hinders you.
xte 'key Caps_Lock'

# Simulate pressing a key combination
xte 'keydown Shift_L' 'keydown Control_L' 'key u'

# Simulate releasing a key combination
xte 'keyup Shift_L' 'keyup Control_L'

# Restore Caps_Lock to the previous state.
xte 'key Caps_Lock'

I tested this in PhpStorm 2018.2 EAP Build #PS-182.3458.35, and I can say that it works, but with some caveats:

  • this works slowly (on my rather old PC)
  • during the execution of the script, it is better not to press any keys
  • sometimes it may not work
  • sometimes it can enter an infinite loop. Therefore, it's better to add a check to the script that the script is already running.

In general, if you do not often use this combination, then this solution may suit you.


None of the solutions here worked for me. In the end I had to disable the daemon completely.

mv /bin/ibus-daemon /bin/ibus-daemon.bak

Then rebooted my computer.

It still does the Ctrl+Shift+U unicode thing in Terminal and Firefox.

But no longer does it in VS Code, Jetbrains Rider, DataGrip, or NotepadQQ.


If you don't need the system for entering non-Latin characters provided by iBus, uninstall it and reboot:

$ sudo apt remove ibus
$ sudo reboot
  • 2
    And if you have trouble removing ibus because zoom depends on it, see this page for how to remove the (incorrect) dependency from zoom to ibus: hashman.ca/zoom Commented Apr 12, 2021 at 9:33

To change it on terminal (instead of GUI), for example to Ctrl + Shift + Super + u:

# Get
gsettings get org.freedesktop.ibus.panel.emoji unicode-hotkey

# Set   
gsettings set org.freedesktop.ibus.panel.emoji unicode-hotkey "['<Control><Super><Shift>u']"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .