ctrl+shift+u is a combined shortcut key in Eclipse.

But when I press it, it shows up a u, just like input with an underline. I guess this shortcut has been declared by Ubuntu, so I can't use it.

I used to solve this problem by typing capslock first. Is there any better method?

11 Answers 11


Found a way to unbind it on Ubuntu 13.10.

Go to Language Support on System Settings and change the Keyboard input method system to none

Then restart the system or just log out and log in.

| improve this answer | |
  • 11
    Just logging out and back in works for me. – Martin Apr 29 '14 at 10:13
  • In latest Ubuntu versions you just go Language Support then Keyboard input method system is available – Vahid May 30 '18 at 21:26
  • 19
    This did not work for me on Ubuntu 18.0.4 LTS. Any ideas why? – Pytry Jun 19 '18 at 22:05
  • 3
    why Ubuntu made it so difficult to disable keyboard input system? keystrokes entered going directly to program should be the default anyway. – weima Jul 18 '18 at 15:08
  • 8
    does not work for me on ubuntu 18.04 – iRaS Aug 22 '18 at 8:59

Ubuntu 18.04 Solution

@ShmulikA's answer was close, but unfortunately, selecting "None" did not work for me. I can confirm the process below works in 18.04 as of April 2019.

  1. Open Search using Super key (aka WIN for folks like me)
  2. Type "language support" and hit ENTER

enter image description here

  1. Click the Keyboard input method system dropdown menu and select XIM

enter image description here

  1. Click Close
  2. Reboot

When I logged back in, I was able to set CTRL+SHIFT+U as a shortcut in Visual Studio Code.

| improve this answer | |
  • 3
    Great, works perfect with Android Studio shortcuts. Thanks a lot. – Juan Ignacio Barisich Apr 17 '19 at 11:47
  • 2
    worked for me even without applying system-wide. Thanks! – grreeenn May 24 '19 at 12:42
  • 3
    Worked on Linux Mint. Thanks! I'm finally free again! – André Valenti Jun 13 '19 at 18:32
  • 1
    opening the dialog (1.+2.) can also be done by $> gnome-language-selector – Frank Nocke Sep 11 '19 at 10:22
  • 1
    This unlocks the key binding but messes up some applications. Dconf Editor is very glitchy now and DBeaver became unusable. How hard can it be to disable a fraking shortcut, Ubuntu? – Rafał G. Oct 1 '19 at 7:58

I use Ubuntu 18.10 and had trouble in a particular app (Intellij Idea).

In this askUbuntu answer, Kayvan Tehrani shows a setting that works for me in that setting. Set the XMODIFIERS to an empty string before running your application:

export XMODIFIERS=""

In my case, myapp.sh was idea.sh, and I added the line inside the file:

# ---------------------------------------------------------------------
# IntelliJ IDEA startup script.
# ---------------------------------------------------------------------
export XMODIFIERS=""

This way, my desktop shortcut still works.

XMODIFIERS apparently changes the way xim and ibus works, and when it's cleared, it disables the CTRL-SHIFT-U combo, allowing it to filter into the current app.

| improve this answer | |
  • The broken Ctrl-Shift-U behaviour has been bugging me for almost 2 years now, and your solution is the only one I have tried that works. – Dave Cole May 22 '19 at 23:49
  • Do you know of any documentation that explains what XMODIFIERS does exactly? Does this have a any side effects? – Matthijs Kooijman Mar 28 at 9:20
  • @MatthijsKooijman, bu default on Ubuntu 18.04 it used for Unicode input. For example, Ctrl+Shift+u2764Enter inserts a "heavy black heart". Unicode character. Demonstration: ❤ – Volodymyr Fedorchuk Apr 18 at 11:57

Changing the input method as PutzKipa explains actually fixes the problem.

However, I've failed to find any configuration panel under KDE ubuntu 14.04 to do the job, and the standard im-config utility seems broken. I finally succeeded by creating a file ~/.xinputrc that contains a single line:

run_im xim

then logout/login. This chooses xim as the input method (ibus is the default). If you remove your ~/.xinputrc, then im-config can list the input methods available, even if it fails to select one.

| improve this answer | |
  • 1
    this also doesnt seem to work in 16.04 LTS – weima Jul 18 '18 at 15:10

Ubuntu 18.04

Running into this problem on Ubuntu 18.04, I've tried all suggestion above, but unfortunately none of them worked. I ended up uninstalling the ibus package.

Background / sidenotes

I tried to disable IBus using

  1. the Language Support menu
  2. im-config (configures ~/.xinputrc)
  3. sudo im-config (configures /etc/X11/xinit/xinputrc)

I noticed however that no matter what config I tried, the ibus daemon was running everytime after I had rebooted.

| improve this answer | |
  • I think it is the best solution. Remove it and forget about that keymaps issues in Intellij – Vitalii Diravka Jun 4 '19 at 15:05
  • I ended up uninstalling the ibus package. – on my Ubuntu 18.04.3 the ibus package wasn't installed in the first place (I could not run ibus-setup for example, until I installed the package), yet I had a working Emoji-Editor (to my dismay, presseing ctrl-. in Pluma for example) and the ctrl-shift-E issue. – Frank Nocke Sep 10 '19 at 16:42


The problem is that with the "Ibus" input method, "Ctrl-shift-u" is by default configured to the "Unicode Code Point" shortcut. You can try this: Type ctrl-shift-u, then an (underlined) u appears. If you then type a unicode code point number in hex (e.g. 21, the ASCII/unicode CP for !) and press enter, it is replaced with the corresponding character.

Example of ctr-shift-u


This shortcut can be changed or disabled using the ibus-setup utility:

  1. Run ibus-setup from the terminal (or open IBus Preferences).
  2. Go to “Emoji”.
  3. Next to “Unicode code point:”, click on the three dots (i.e. ...).
  4. In the dialog, click “Delete”, then “OK”.
  5. Close the IBus Preferences window.

Ibus preferences window

| improve this answer | |
  • Wow! Thank you kleinfreund, this solution is the best way to fix the issue. Much better than changing "Keyboard input method system". – Pavel Prischepa Nov 6 '19 at 8:35
  • This worked in 18.04 for me, but fails in 20.04. – Phill Apr 7 at 9:11
  • @Phill Indeed, for me, too, this no longer works. Even though it clearly should. It doesn’t seem to work in either 19.10 or 20.04, unfortunately. – kleinfreund Apr 7 at 14:59
  • @kleinfreund I figured out a way by renaming the IBUS daemon mv /bin/ibus-daemon /bin/ibus-daemon.bak and rebooting. This killed it for me finally. – Phill Apr 8 at 6:20
  • Ubuntu 18.04.4 ibus-setup has emoji shortcuts, but no unicode chortcuts settings : ( – yurenchen May 9 at 10:58


export GTK_IM_MODULE="gtk-im-context-simple"

and then run Eclipse from the same shell. Or if that doesn't work,

export GTK_IM_MODULE="xim"

(This test only works entering running the export command and then Eclipse from the same shell command line, it won't change anything if you use a desktop shortcut or the Applications menu, or run Eclipse from a new shell.)

If either test works, you can make the change system-wide by adding it to /etc/environment, or per-user in ~/.gnomerc. (The export command doesn't go in those files, just a new line with GTK_IM_MODULE="xim" or GTK_IM_MODULE="gtk-im-context-simple".)

It sounds like this behavior comes from GTK's input mappings as described here.

... This is called preediting, and an input method may provide feedback about this process by displaying the intermediate composition states as preedit text. For instance, the default GTK+ input method implements the input of arbitrary Unicode code points by holding down the Control and Shift keys and then typing “U” followed by the hexadecimal digits of the code point. When releasing the Control and Shift keys, preediting ends and the character is inserted as text. Ctrl+Shift+u20AC for example results in the € sign.

GTK is used by a whole lot of common apps in Ubuntu, including Eclipse.

| improve this answer | |
  • seems ubuntu18.04.4 not work – yurenchen May 10 at 1:54

Ubuntu 14.04/18.04 Solution

recently upgrade to 18.04 and fight my way to solve this issue.

  1. open search using super key
  2. go to language support
  3. click Keyboard input method system dropdown menu and choose none

Language Support Menu

  1. dont forget to click - apply system wide
  2. close the window (wont activate until you do)
  3. reboot (logout might be enough)

Credit goes to reverse issue on askubuntu - for some reason someone wants to enable this shortcut.

| improve this answer | |
  • 1
    This solution did not work for me. Should I also reboot? (I have too many windows opened now and cannot test it quickly) – desa Sep 30 '18 at 11:58
  • works after reboot (maybe logout is enough) @desa thanks ill update the answer – ShmulikA Oct 2 '18 at 11:21
  • 3
    does not solve the problem in 18.04 – James Nov 21 '18 at 14:55
  • 1
    This solution does not work in 18.04, even after a reboot. @ShmulikA, are you sure that's all you had to do? Was there another step? Followed your steps exactly, no luck. – Brown Apr 5 '19 at 16:53

For Ubuntu 18.04.

I struggled with this problem for two days. I tried all the methods listed here earlier. And it looks like I came up with a solution. But it is very unstable and has bugs.

The basic idea is this: in the system settings you can specify the command that is started by the Ctrl+Shift+U key combination.

Note: if you specify false as the command, the combination will not work at all.

However, we can specify the path to the script as the command, in which we will simulate pressing the same key combination.

To simulate keystrokes, I tried the xdotool (apt install xdotool) and the xte (apt install xautomation). Both options were unstable. However, xte turned out to be more flexible for me.

Example with xte

  • Create a file /home/username/shortcut.sh
  • Add permission to execute: chmod u+x /home/username/shortcut.sh
  • Specify the path to the script as a command for the Ctrl+Shift+U key combination in the keyboard settings

Here is an example script:

# Make a small delay in order to have time to release the keys.
sleep 0.2

# Simulate the release of just pressed keys, if they are still pressed.
xte 'keyup u' 'keyup Shift_L' 'keyup Control_L'

# Hack: Caps_Lock is used so that the system does not intercept this combination.
# You can try to remove it if it hinders you.
xte 'key Caps_Lock'

# Simulate pressing a key combination
xte 'keydown Shift_L' 'keydown Control_L' 'key u'

# Simulate releasing a key combination
xte 'keyup Shift_L' 'keyup Control_L'

# Restore Caps_Lock to the previous state.
xte 'key Caps_Lock'

I tested this in PhpStorm 2018.2 EAP Build #PS-182.3458.35 and I can say that it works, but with some caveats:

  • this works slowly (on my rather old PC)
  • during the execution of the script, it is better not to press any keys
  • sometimes it may not work
  • sometimes it can enter an infinite loop. Therefore, it's better to add a check to the script that the script is already running.

In general, if you do not often use this combination, then this solution may suit you.

But, probably, someone will come up with a better and more stable solution.

I hope this idea will help someone.

| improve this answer | |

None of the solutions here worked for me. In the end I had to disable the daemon completely.

mv /bin/ibus-daemon /bin/ibus-daemon.bak

Then rebooted my computer.

It still does the Ctrl+Shift+U unicode thing in Terminal and Firefox.

But no longer does it in VS Code, Jetbrains Rider, DataGrip, or NotepadQQ.

| improve this answer | |

If you don't need the system for entering non-Latin characters provided by iBus, uninstall it and reboot:

$ sudo apt remove ibus
$ sudo reboot
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.