9

My home network setup looks like this:

My home network setup

Both routers are TP-Link TL-WR1043ND routers. The basement router handles all devices in the house that are connected via cable, handing out addresses for the 10.89.49.0/24 network via DHCP. Wireless doesn't really work from the basement, as the signal is too weak, so I have disabled it.

To do WiFi, I have added a second (identical) router downstairs. On the WAN side it is assigned the 10.89.49.101 IP address from the basement router, and on its LAN it provides the 10.89.7.0/24 network. Basic Internet access works flawlessly from any device this way.

I am now facing the problem that I am not able to communicate (e.g. SSH) between all devices, wired or wireless. I am able to connect from a wireless device to a wired device, for example SSH-ing from 10.89.7.X to 10.89.49.Y, but it doesn’t work the other way round, despite the fact that I have added a static route to the basement router:

Static route configuration on the basement router

Does anyone have any ideas how to solve this problem? Both routers have already been upgraded to use the most recent firmware from TP-Link.com (Build 110429), to no avail.

I would like to stick with the official firmware if possible, only switching to something like DD-WRT or OpenWrt as a last resort.

3
  • Shouldn't the static route point to 10.89.49.0/24, so traffic from the basement router knows where the upstairs router is? – dannymcc Nov 18 '11 at 8:57
  • This makes no sense to me. The basement router already handles 10.89.49.0/24, and it also provides the 10.89.49.101 IP address for the other router—so it should know exactly where the WiFi router is. – igor Nov 18 '11 at 9:09
  • You're right, sorry! I was looking at the diagram the wrong way around - reading the basement as upstairs and vica-versa. – dannymcc Nov 18 '11 at 11:58
4

I know what's going on. You leave clear with the address you are using on the routers and what you say: "I am able to connect from a wireless device to a wired device, for example SSH-ing from 10.89.7.X to 10.89.49.Y, but it doesn’t work the other way round" The way you have set it up, doesn't allow it.

Since you wanted all devices to communicate with each other, you shouldn't have them in different LANs rather use the same for all devices. So you network arquitecture approach failed there.

Let Router1: be the router directly connected to the internet Router2: be the other one.

What I would do is disable the LAN DCHP Server on the Router2 and change the cable from WAN to LAN. (Cap WAN port) Also, give it (Router2) a Router1 LAN IP Address on its LAN port, so you will be able to get to it via its HTTP Server

1
  • But why can't you allow different LAN's to communicate with each other? I am having the same issue with my config. I also have a static route in Router 1 and that should make computers in LAN 1 to be able to communicate with computers and LAN 2. Why doesn't it work? – andrepcg Oct 20 '18 at 15:32
0

The first thing I would suggest is plug in a test machine into the internet-connected router. Manually give it an IP and set a route on it to the other router.

If you have Linux, it would be something like this: ip addr add 10.89.49.x/24 dev eth0 ip link set up dev eth0 ip route add 10.89.7.0/24 via 10.89.49.101 dev eth0

Then try pinging 10.89.49.101 (to verify you can hit the wan interface of your router) and then try pinging something beyond it like 10.89.7.1.

If you can't find .1, it's probably a NAT or Firewall issue. Firewalling may be preventing traffic from the WAN interface from reaching the LAN. Unless you have a reason to enable it, I would consider disabling the all firewalling on the device. (Hopefully the manufacturer supports that).

Lastly, check if the router has NAT settings. If NAT is enabled it may be expecting you to explicitly set forwards for ports on 10.89.7.101 to machines and ports in 10.89.7.0/24.

If you don't have a Linux test machine, consider downloading a Live CD to do the testing or someone else can comment and tell you how to do that in Windows.

0

I am not sure if answering this question will add any value to this problem as it was posted about 6 years ago!

After carefully reviewing your diagram and reading answers above, I understand the configuration preventing both way communication. TP-Link type Consumer router (SOHO) expected to operate as stand alone internet gateway device most of time and to allow non-technical user to start using these devices NAT on LAN>WAN traffic set by default. On your network any traffic originating from 2nd router reaching open internet after having at least 2 destination NAT header on every packet.

able to connect from a wireless device to a wired device, for example SSH-ing from 10.89.7.X to >10.89.49.Y, but it doesn’t work the other way round

When you ssh on 10.89.49.Y network, traffic ssh-server host see connection originating from 2nd router's WAN interface (10.89.49.Y IP), 10.89.7.x actually never going out crossing 2nd router.

So without resetting your cable or other configuration, just disable NAT on 2nd router. (On TP-Link it might show as 'Wireless AP' mode, not 'Wireless Router Mode'.

Hope your problem already gone long ago...

0

While looking for an answer to my current situation I came upon your question and tried to see if it might be something to help me. Alas, no.

But, it seems you must configure routing on both devices if you're using WAN ports. While you've configured routing from router 1 to the network of router 2, router 1 will send all the data packets but it won't get anything back because router 2 doesn't allow it (I think it's the 10.89.7.* one). Access 2nd router's Static routing list and add the reverse path and now they should play nice together.

I too have two TP-Links, but of different models and that's the only way I was able to get access between two different networks per your topology.

However, the proposed answer by Salvador Seekatz is a better way to solve the problem on your small network, imo. Advanced routing and multiple networks is for different needs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.