3

I'm trying to change the resolution on my base shell (the Ctrl+Alt+1) shell in Debian so that it supports my ViewSonic monitor.

The shell appears really fuzzy when it is displayed on my lcd monitor, but GRUB looks fine when it's displayed.

In I tried changing part of the GRUB_CMDLINE_LINUX_DEFAULT to 'vga=ask', and now I get the error on booting up 'Legacy 'ask' parameter no longer supported'

Has this 'vga=ask' value been changed to something else?

Note, I tried setting it to 'vga=782' after finding a list of screen modes here and the shell font got real huge for a few seconds during boot up, and then switched back to it's awful fuzzy self again, when I went to use the Debian Bash shell.

UPDATE
Tried suggestion in this question, it works without fuzziness until the last resolution change which displays the user login to the shell.

  • 1
    I'm probably setting the grub resolution and not the shell resolution :-p – leeand00 Nov 19 '11 at 3:40
  • Another font (than kernel default) is loaded during the boot process. You can usually disable that by editing /etc/conf.d/consolefont or somesuch. Look for /etc/init.d/consolefont and try to figure out where it reads configuration parameters. – Ярослав Рахматуллин Nov 20 '12 at 14:29
0

vga=ask is handled by the bootloader, not the kernel (it's some ugly kludgy voodoo involving the BIOS and magically rewriting the kernel command line, IIRC).

If you use the 16-bit versions of the linux and initrd grub commands, namely linux16 and initrd16, vga=ask will still work. Just edit your boot entry from the menu and replace linux /vmlinuz-... with linux16 /vmlinuz-... and the same with initrd.

If you want to make this permanent, you'll have to modify /etc/grub.d/10_linux to generate linux16/initrd16 commands instead of initrd and linux.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.