When I plug my laptop in to the original manufacturer's AC adapter, my laptop battery charges.

When I plug it into a cheap replacement (i.e. non-Dell) adapter, it stops using the battery, but will not charge.

Here's the details:

  • The laptop is a Dell XPS M1530.
  • I've verified that both the original and knockoff are specified for the same wattage (90 W AC), input (AC 100 - 240V, ~ 1.5 A, 50 - 60 HZ), and output (19.5 V, ~ 4.62 A).
  • I am using Windows Vista.

I did get a message about some sort of power issue when booting on the knockoff adapter, but unfortunately I dismissed it ("don't show this again") before I realized the battery wasn't charging and don't know how to get it back.

Any ideas? Do I just write it off as a lesson in not buying non-manufacturer AC adapters?

  • 1
    For those people reading along who are not native English speakers: knockoff=an unauthorized, cheap copy of something
    – Jan Doggen
    Sep 16, 2013 at 7:04
  • It is a driver in the OS. Once running the OS controls it. If you boot into Linux it charges.
    – user518289
    Nov 5, 2015 at 15:37

6 Answers 6


3rd-party adapters might not have the same efficiency as the original charger, and their QC is usually much worse.

However, if you can use the notebook - I suspect the case is the former - the adapter is not supplying enough power (because of its non-efficiency) to power the notebook and charge the battery at the same time. It's one or the other.

Shutdown your notebook - see if the battery charges.

  • 1
    I see this is accepted - so did the battery charge or not?
    – MGOwen
    May 27, 2010 at 1:51
  • The problem was using a knockoff adapter. Problem was solved when I bought a Dell adapter. Sep 18, 2013 at 18:54
  • I've seen this happen when I plugged a physically and electrically compatible HP adapter (which actually had higher output, 90W vs 60W) into a Dell laptop. The system would run off the adapter, but not charge the battery. HP laptops aren't as picky, but they obviously do need a sufficiently powerful adapter. When I plugged the Dell adapter into my HP laptop, it would charge, but the system warned that the adapter was not supplying enough power to run the system at full performance and may throttle as a result: "For full performance, connect a higher capacity Smart AC Adapter."
    – bwDraco
    Aug 11, 2014 at 16:56

The Dell AC adapter contains a chip that identifies it as an approved AC adapter. If you try to use a third party AC adapter on a recent Dell adapter then since it doesn't have the special chip that identifies the AC adapter as being Dell approved then the laptop declines to charge from the AC adapter.

There are a couple third party AC adapters that contain the special chip that identifies the adapter as being Dell approved. The iGo.com adapters are one such third party AC adapter. They sell specialized “tips” that contain the necessary chip to provide the proper identification to the laptop.


  • This sounds very likely, considering the crazy high price of Dell's own AC adapters, but a quick check of your link and the rest of the igo website says nothing to confirm (1) The id chip exists (2) the igo contains such a chip (3) the igo tips can be used with non-igo adapters (the igo adapters seem even more expensive than the dell ones(!) which defeats the purpose) Can you please add some links to back this up?
    – MGOwen
    May 26, 2010 at 1:23
  • Dell cables are three wire, the presence of the third wire and the identifier are necessary for the charging system to work. This is especially important if any LiPo battery packs are in the equation. That added expense might prevent other more expensive issues. Dec 1, 2012 at 18:37

Sounds like the knockoff AC adapter isn't meeting their own specs. If this is the case, can you return it as defective?

  • Unfortunately, I only noticed the battery wasn't charging long after my return period. (This is because I very rarely run my laptop off the battery.) Sep 4, 2009 at 19:59

I have a Dell studio 1737, and out of nowhere, I get a popup message in Windows that tells me that I need to have a power supply that meets Dell's requirements.

Screen snapshot of Dell AC Adapter message

Like others I can power the laptop and use it just fine with the adapter. The blue LED in the adapter end that plugs into the laptop is lit up. When I unplug it and plug it back in, that the LED on the laptop itself, which indicates that the battery is charging or charged, initially lights up but only for about a second. Then it goes off and the dialog box pops up.

Tried a lot of things. Restarting the computer. Unplugging the adapter from the wall. In the BIOS, it says it's unrecognized as well, so Dell is rejecting it's own adapter at a hardware level on the motherboard. If there is some kind of "chip" in the adapter that Dell looks for and rejects if not present, then apparently that chip has failed (Burned out? Static electricity got it?)

If this is the case, then it's a prickly move by Dell to add hardware for the sole purpose of requiring you to purchase only their product directly from them at an inflated price, and then to have that part of the device fail when it actually is a genuine Dell that I purchased from them.

Dell wants $66 for a replacement adapter. Just bought one on ebay for $8.18 on ebay.

Update: Plugging my adapter into a friends Dell laptop works fine. Plugging in his adapter in mine fails in the same way. Removed battery from my laptop and plugged in cable. Same problem.

So I've concluded that it's not the adapter. It's not the battery. It's the laptop itself that seems to be the problem. Thank you Dell for making a fussy motherboard that decides to stop recognizing a perfectly good, genuine Dell AC adapter.

  • It's not a software problem because you can boot into the BIOS and see it there. I've upgraded the BIOS to the latest, thinking it would resolve the issue, but the latest BIOS software (A09 I think), does the same thing. While on my friends computer, my adapter and the new one I bought both work fine. Apparently the sockets for these DELL motherboards are notorious for going bad or breaking solder joints and being difficult to replace. Thanks for the suggestion though.
    – Monkey47
    Apr 18, 2013 at 14:36
  • 1
    Sometimes, the power port gets damaged such that sensing doesn't work. It's a known issue with Dell machines.
    – Bob
    Sep 16, 2013 at 4:09
  • @Bob, that's basically what I've come to the conclusion of myself in my case. Thank you DELL for building in this hardware feature and then making the female socket for the power adapter inferior. Dell should fix this for free, IMO. It's only the most critical function of the laptop... to be able to charge the battery.
    – Monkey47
    Sep 17, 2013 at 13:22
  • @MarkS to double check, have you tried with linux e.g. a linux usb bootable? you'd get the bios unrecognized battery.. but do you also get the light lit temporarily? I suppose the problem -with both symptoms- would be with ubuntu too.. and would just confirm what you said that it's hardware. "sunny" posted a comment as a question, now removed, asking if the same problem occurred with linux.
    – barlop
    Aug 11, 2014 at 16:57

Try unplugging the Dell adapter from the the AC outlet and see if it acts like the knockoff. Actually measuring the output would be better than reading the label, but I know not everyone has a voltmeter.

  • Many power supplies have no output without a load. Sep 5, 2009 at 10:50

Contacts become worn, bent and dirty over time. I would suggest trying to clean the power connector port with contact cleaner. Since it is female, there wouldn't be much you could do on the male side except bend it ever so slightly to force contact. I've heard (though not proven) that this can occur with laptop battery connectors also. IMO, connectors on computers in general are pretty flimsy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.