So I bought a new AC Freezer 7 Pro to replace the stock cooler. I fixed it on, and at first it only works for a few seconds, then shuts off. Of course, I realised it was the thermal shutoff. I saw that the fan had come loose, so I fixed it on, and tried again. Still no joy. I checked the fan once more, and found it was very securely fixed. I tried once more, to find it doesn't power on at all. I get lights on the motherboard, but when I press the button, there is no response whatsoever. (I also tried touching the pins with a screwdriver, just in case the button didn't work)

Now I'm rather confused about this. I know that the processor automatically shuts off when it reaches 85 degrees, so no permanent damage can be caused by faulty cooling. Any ideas anyone?


Ah, no I didn't clean off the original paste. I know you normally should, but how could it make that much difference?

FYI, it's a 775 socket, so I simply untwisted the 'spikes' of the stock cooler, then lifted it out, placed in the new cooler (with thermal paste) and pushed in the 'spikes', until it was secured to my satisfaction. I've done quite a few of these in my time, so I'm pretty sure it was well secured.

  • 2
    Did you clean off the thermal paste from the processor, before spreading a new layer of thermal compound? – Aki Nov 20 '11 at 15:57
  • Describe in as much detail as you can the process you used to remove the old cooler and install the new one. – David Schwartz Nov 20 '11 at 19:41
  • 1
    I'm thinking that it would take a minute or two for the absence of a fan to cause overheating, so if it shut off "after a few seconds" then likely something else was wrong. – Daniel R Hicks Nov 20 '11 at 21:48

Have you tried removing and replacing the cpu, you may have knocked it out of position when you fitted the fan.

It is possible that in fitting the fan you have crushed or distorted some of the pins on the motherboard or just nudged the cpu out of alignment. Remember that LGA IS Land Grid Array and that means that the pins are no longer on the cpu so it is potentially easier to knock the cpu sideways and cause a problem that way.

  1. You should always remove old crusty thermal grease/paste/tape from a stock cooler. They use the cheapest stuff available, and a 5$ tube of AS5 is always worth it. (Or your other favorite HQ thermal compound)

  2. You should first try unplugging the AC cable from the PSU for a minute, and attempt a boot. If you still don't POST, try resetting the CMOS. Reset preferably via the correct jumper, or if all else fails remove and reinsert the CMOS battery.

  3. If you still don't power, it is very possible your new cooler/fan is drawing much more power than your old one. You might not have a strong enough PSU for this new load, Try disconnecting some unnecessary internal drives. I have actually seen this, a significant number of times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.