39

Until now, I have never attempted adding a crontask on my Mac. To my surprise, it threw an error..

[hayek@mac:/www/] 02:33:22 PM: crontab -e                                                                                                         1 .
crontab: no crontab for hayek - using an empty one
crontab: "/usr/bin/vi" exited with status 1

How can I figure out why it's throwing that error?

I'm running Mac OS X Lion 10.7.2

8
  • 2
    Are you using cron for a specific reason? On OS x it's largely been superseded by launchd
    – Daniel Beck
    Commented Nov 20, 2011 at 22:48
  • I wanted to use vnstat to track bandwidth usage, which requires a cronjob. I know I could use an alternative app, but it would still be useful to know how to make cron work on Mac, if at all possible.
    – Hayek
    Commented Nov 20, 2011 at 23:10
  • 1
    Have you tried crontab file to install the table from an external file? Or using a different editor like EDITOR=NANO crontab -e?
    – Lri
    Commented Nov 21, 2011 at 6:22
  • 1
    @DanielBeck I use cron because it's much quicker to set up a new entry than launchd. Commented Nov 21, 2011 at 18:32
  • What does crontab -l show? Are there any other messages in /var/log/cron.log or /var/log/system.log? Commented Nov 21, 2011 at 18:38

9 Answers 9

43

In ~/.vimrc add:

    autocmd filetype crontab setlocal nobackup nowritebackup
5
  • great simple trick! works well for me.
    – Tri Nguyen
    Commented Jan 3, 2017 at 17:20
  • This is the best answer and works well - much simpler than the one involving setting an env variable in the shell profile as well as editing ~/.vimrc
    – RichVel
    Commented Jul 24, 2017 at 6:40
  • Marking this as the correct answer since my own reply is no longer appropriate nor the most effective.
    – Hayek
    Commented Dec 28, 2017 at 0:31
  • 1
    This works in Mac OS High Sierra too! Thanks for posting this Commented Jan 10, 2018 at 17:10
  • 1
    Can anyone please explain why this works? Commented Jun 10, 2021 at 23:14
44

The issue turned out to be vi and nothing to do with cron. Doing export EDITOR=vim fixed it

8
  • 2
    Yes i understand you found the issue, and the solution is... what? Commented Oct 16, 2012 at 14:02
  • 3
    Try doing export EDITOR=vim then giving it a go.
    – Hayek
    Commented Oct 16, 2012 at 21:56
  • Thanks @Hayek. Sorry for latency, i couldn't responsed as quickly as you did :P. However, running crontab with the almighty 'sudo' solved my problem. Commented Oct 21, 2012 at 6:49
  • Glad you got it working.
    – Hayek
    Commented Oct 21, 2012 at 7:36
  • 1
    I have just had the same issue. Setting EDITOR=vim did not fix it -- it just led me to a new error crontab: temp file must be edited in place. I much prefer vim, however i edit cronjobs so infrequently that i'm happy enough doing it in NANO ... though if someone knows the fix, i'm very interested.
    – ricardo
    Commented Mar 10, 2013 at 5:38
35

On a related issue, if you get the message:

crontab: temp file must be edited in place

Try:

1) Add to .bash_profile

alias crontab="VIM_CRONTAB=true crontab"

2) Add to .vimrc

if $VIM_CRONTAB == "true"
    set nobackup
    set nowritebackup
endif

Source: http://drawohara.com/post/6344279/crontab-temp-file-must-be-edited-in-place

6
  • 3
    This is the correct answer!!
    – Jay
    Commented Sep 3, 2014 at 2:09
  • 1
    This worked for me and I feel this should be the correct answer.
    – Shubhamoy
    Commented Nov 17, 2016 at 17:05
  • 1
    For csh or tcsh, use alias crontab "export VIM_CRONTAB=true; /usr/bin/crontab" Commented Nov 22, 2016 at 19:15
  • 1
    I also think this is a better answer although the question from the OP does not mention the exact error @xgMz described. crontab does not appear to like the vim backup on write/save behavior so disabling it as described here just works. Commented Mar 22, 2017 at 18:08
  • 1
    I just had this issue with vim and cron on macOS Sierra. This is the correct answer! Commented Apr 30, 2017 at 9:39
8

Your editor on system variable EDITOR is vi and vi itsn't work.

Try:

export EDITOR=nano
2

I had the same problem and followed the advice posted for creating the table:

crontab file

And that created the cron table, and then I was able to run

crontab -e

with vi as the default editor and had no problems. It is as if vi could not save the file, but once created, it could access it. This is consistent with being able to run:

sudo crontab -e 

As a curiosity, the tables are stored in

/usr/lib/cron/tabs/UserName

which can only be read as sudo.

0

The best way to diagnose this would be to create a fresh crontab with a simple entry like:

* * * * * /bin/date >> /tmp/cron_output

If that works then the issue is with the specific command you've added. Could you share it with us, and also share the results when you execute it directly from Terminal.app, rather than from a crontab?

2
  • 1
    Same error with the command you suggested. In terminal, /bin/date returns Wed Nov 23 15:03:49 PST 2011 as expected.
    – Hayek
    Commented Nov 23, 2011 at 23:04
  • OK, just seen your answer, which explains why you'd get the same error - just thought it might help to diagnose the problem :)
    – tog22
    Commented Nov 24, 2011 at 11:55
0

cron is deprecated in favour of launchd.

Lingon is a great little tool for setting up launchd agents; it used to be free but appears to now be $3.

Wikipedia has a good launchd page describing all the keys and the launchctl tool you use to activate/deactivate them.

0

Adding au BufEnter /private/tmp/crontab.* setl backupcopy=yes to vimrc fixed it for me. See here:

http://vim.wikia.com/wiki/Editing_crontab

-1

I saw this same issue on OSX. The answer is to run as root using the sudo command, e.g.:

sudo crontab -e

I got that idea from Gökhan Barış Aker above.

1
  • with sudo you are going to place cron jobs under root user. The cron files are different for your normal user and the root one.
    – Timofey
    Commented Sep 6, 2015 at 0:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .