1

I am trying to convert .mov videos to mp4(should be playable in iPhone) using ffmpeg.I am using Linux CLI. I have tried the following command:

-i source.MOV -s qvga -b 384k -vcodec libx264 -r 23.976 -acodec libfaac -ac 2 -ar 44100 -ab 64k -vpre baseline -crf 22 -deinterlace -o output.mp4 

I get the output

ffmpeg: unrecognized option '-o' 
| improve this question | | | | |
  • Please clarify your question, what have you tried that didn't work, are you writing a program to do this or just trying to it manually? – jrturton Nov 21 '11 at 12:40
  • @jrtuton ,I just tried to execute this command ffmpeg -i source.MOV -s qvga -b 384k -vcodec libx264 -r 23.976 -acodec libfaac -ac 2 -ar 44100 -ab 64k -vpre baseline -crf 22 -deinterlace -o output.mp4 I got the error ffmpeg: unrecognized option '-o' – Rinto George Nov 21 '11 at 12:42
  • I don't think this is a question for SO, it is a support question for ffmpeg. – jrturton Nov 21 '11 at 12:47
  • @jrturton: That, or SuperUser. – DarkDust Nov 21 '11 at 12:50
5

For this kind of tasks, I switched from FFmpeg to HandBrakeCLI:

HandBrakeCLI -i source.mov -o destination.mp4 --preset='iPhone & iPod Touch' 
| improve this answer | | | | |
  • I think HandBrakeCLI is windows tool ,I need it in linux – Rinto George Nov 23 '11 at 6:04
  • HandBrakeCLI runs on Mac OS X, Windows and Linux, check its download page. – mouviciel Nov 23 '11 at 8:19
  • I've used this command in CLI ,its working ,but converted videos playing only seconds when the original video have long way to go – Rinto George Dec 5 '11 at 5:16
3

There is no -o to output a file. Just remove it and pass the desired output filename as the last argument.

| improve this answer | | | | |
  • Can you give me some working commands ,cause we don't have an iPhone,if I could convert it ,but can't play .I really wanna convert .mov ,.wmv to mp4 – Rinto George Nov 21 '11 at 12:56
  • Your answer actually solves the problem, the above answer just proposes alternate. – Pj_ May 23 '17 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.