I have a PHP website on a Windows 7 machine I'm working with and it cannot be viewed by any browser - IE, Chrome, Firefox. When navigating to the root of the website (default index.php) the browser reports it cannot find the address. Not a 404 error from the webserver, just as if it cannot resolve the name. Other websites in the same default web application that are also PHP work perfectly. I've aligned all folder permissions and everything else but this has got me stumped. I even went as far to create a new folder and throw in a test phpinfo() page and it worked. Copied this website's content to the new folder and it cannot find the index.php page. I checked all setting I know and can't seem to find what I'm missing. Anyone else encounter this issue? Remember the fix for it?

  • Could you please add to your post an example of a url that works and the one that doesn't ? – harrymc Nov 21 '11 at 18:11

Something to try:

1) Make your phpinfo page again and verify that it is working.

2) copy/paste the content of the actual index.php file you want to use into your working phpinfo test page. (that is, open your working test page in a text editor and paste the actual page's text into it)

3) see if it works!

I had plenty of fun troubleshooting a few php pages a few years ago, it turned out the file I was working with had hidden symbols on line 1 that I couldn't see in the text editor I was using!

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.