Possible Duplicate:
Why is my USB mouse disconnecting and reconnecting randomly and often?

I've bought an acer aspire 5742G about 2 months ago or so and it's been running great, but sometimes I used to hear the windows error beep but I had no idea what was causing it since the "bug" was automatically fixed so fast I couldn't even see an error message (also it kinda always happened when I was busy also, either in a game or while doing my homework).

Later on my mouse would simply not work for 3-5 seconds then work again, I thought nothing of it at the time. I also had a problem where it only worked in one usb and one only. To move it I had to remove the battery, unplug the laptop and hold the power button for 2 minutes to reset the bios settings.

Since today though it went nuts. Sometimes it disconnects / reconnects 12 times in 10 seconds and windows just keeps beeping till I unplug it, then it runs smooth for 5-6 minutes then it goes nuts again. Other times it seems like it skips (disconnects for a fraction of a second) other times just for 2-3 seconds. But this is incredibly frustrating.

Sometimes the power just goes down (the laser turns off) and well that at least I would understand but this is a rare occurrence.

Now I know the usb ports work since I have a lot of other devices connected and I tried the mouse on a room m8's laptop so the mouse also works.

My only conclusion is that it's an operating system / settings bug and / or problem (I have tried the mouse in all ports by the way).

All drivers and bios are up to date (maybe except mouse but I can't seem to update that and the mouse has no name, just a serial number which helps with nothing. Still it worked till today and nothing should have changed any way). I have made sure windows can't shut it down to save power (in device management).

Also I tried to delete the drivers and re-install them, rebooting and the power button trick but nothing. Most I have done is get rid of the 12 disconnects / reconnects every 10 seconds :) but that's all :(

I would buy a new one but I'm afraid it might do the same thing.


Tried the mouse again at a friend but now it didn't even install it's software nor did the update work. Think I'll just buy a new one but I'd still like a suggestion at least so I'll leave this open

#### EDIT 2

Now it works again, I can't explain this. Still thinking of getting a new one though

marked as duplicate by Ƭᴇcʜιᴇ007, Simon Sheehan, Synetech, Gaff, TFM Dec 9 '12 at 18:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • try removing unnecessary details from your question so that people dont go tl;dr and move on – Shekhar Feb 21 '12 at 9:47

After all you tried, it sounds like a bad mouse, or some problem with the USB port. Try getting a Bluetooth mouse - bypasses USB altogether (MS has one for $15-19).


I had exactly the same problem with the same computer (5742G, Win7; mouse model: mini-n5), even after I unchecked all the 'Allow the computer to turn off this device to save power' boxes in USB controllers in Device Manager. I tried another mouse (also Acer, this time the model was m-uvacr1), and the problem persisted.

Then, I tried a Microsoft mouse I received as a bundled gift with some other stuff. The system installed some Intellipoint driver and the problem disappeared completely. The mouse I have now is: Microsoft Basic Optical Mouse v2.0. I believe this is one of many models that will work; still, I'm afraid replacing one Acer mouse with another will not change anything.

I don't want to say all Acer mice must be faulty, but I had two, and you have one, so it looks a bit like a rule than an exception. Other than this, I must say the machine itself works great, and the mouse was the only flaw. By the way, as far as I know, in Europe, you need to buy a mouse separately if you're buying an ASUS or Acer laptop, as it's not included in the package. That seemed strange to me, but now it's not so.


Did you test the mouse extensively on the other computer or just for a second? I had a Microsoft Intellimouse Explorer back in the day that would occasionally disconnect then immediately reconnect. There were some bad solder joints between the mouse cord and the circuit board inside the mouse and the disconnection would only happen occasionally.

You can also try running a "live" version of Linux (ubuntu, etc) off a CD or a USB flash drive to see if the mouse works properly there or if it still screws up. This would rule out any software you may have in your current OS install.

For what it's worth, there are a base set of generic USB device "classes" (which include the mouse) that are so simple that there is no need for drivers for them, ever. They're built into all modern operating systems. The only time you need a driver is if they do something non-standard, like extra buttons for weird features.

  • yeah I just popped it in for a few seconds, now I tried it extensively and it didn't work. Now it doesn't seem to work at all even on my laptop, so I guess it's busted. I'll just try to close this and maybe get it deleted, then buy a new mouse. – Kalec Nov 22 '11 at 16:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.