14

Is there a way to create a Style that doesn't have a font color. The text that I want to apply the font to is already colored (different colors depending on the word), I just want they style to have the font size and background.

  • 1
    Leaving the style's font color on "Automatic" doesn't work? – Ƭᴇcʜιᴇ007 Nov 23 '11 at 1:31
  • 1
    Strangely it changes some text to black but leaves other text colored. – Jonathan Allen Nov 23 '11 at 2:35
  • I can confirm that it doesn't work properly and some words change their colors, whereas the majority doesn't. This seems to be a bug in MS Word. – Alexander Galkin Dec 21 '11 at 16:34
  • From the days I used Word, I remember behaviour would also be different for text that already had less or more than 50% of some formatting applied. Like if one word was bold or using a specific font, it would stay like that. But if more than 50% of a sentence was bold or using that other font, it might be removed when another style was applied. I don't remember the exact details, and don't remember if it applied to color as well. – Arjan Feb 15 '15 at 13:23
  • I have exactly the same problem, but none of the answers here helped. I've reposted as new question for a different version of winword. – BmyGuest Jan 17 at 12:26
7

Styles were a big breakthrough in efficient document production in the early versions of Word, but it has gotten so complicated as to be more trouble than it is worth for most users.

In the style definition, there is a setting for "Style Based On" and one for "Style Type" -

enter image description here

enter image description here

Here you see two default styles built-in to Word 2007. Both have the font color set to blue. Here is the results of applying those styles to text where words have been individually colored:

enter image description here

As you can see, when the "Style Type" is "Linked" and "Style based on" is set to the Normal paragraph style, the color attribute of the style does not override any individual word colors. "Style Type" set to Character and "Style Based On" set to Default Paragraph Font DOES override individual colors.

When you define your own style you'll have choices for "Style Type" as shown here: enter image description here

You should be able to get what you want by choosing Linked for "Style Type" and Normal for "Style Based On" in the style definition.

|improve this answer|||||
  • 2
    You're not actually answering the question. How do you not set the color in a style? – flodin Dec 13 '13 at 10:02
  • "You should be able to get what you want by choosing Linked for "Style Type" and Normal for "Style Based On" in the style definition." That's how you set a style without a color. I did go into a lot of detail on how this works but that's the specific answer. – Dave Becker Dec 13 '13 at 15:34
  • hmm... Office365 doesn't seem to provide a "@defaultparagraphfont" option. – Carl Witthoft Aug 8 '18 at 12:38
  • Found that Style, but Office365 refuses to let me use it - -it's tagged "Hide until used" – Carl Witthoft Aug 8 '18 at 12:47
4

Although this is quite old but today I faced same issue & following is the solution (working in Word-2010):

  1. Use Toggle Button to Show Paragraph Marks
  2. Check that Style shows Style type: Linked (paragraph and character)
  3. Style Formatting Color = Automatic

  4. Select the Text on which you want to Apply the Style.

Caution: Select Complete Paragraph including all the Paragraph marks associated with it.

  1. Apply the Style. It will NOT change the original text color.

I faced similar issue. During Copy/Paste & Applying the Style, sometimes Text color was changed & sometimes it was NOT. Answer of Dave Becker & Following Link helped me resolving this issue:

http://shaunakelly.com/word/styles/stylesoverridedirectformatting.html

:)

|improve this answer|||||
  • I agree, I have a style for which I made sure the color is set to automatic. Most of the time when I apply it to a paragraph that has code-syntax color highlighting ( words has different colors) the style applies correctly. But sometimes, it turns all words in black. Thus as suggested, try to make the selection of the paragraph differently e.g. take one line above or under. You'll see it works :) ... – codea Feb 9 '17 at 14:19
0

You can't actually create a style without a color; every style either has a color specified or inherits the color of its parent style. (Character styles based on the Default paragraph font style inherit font settings, including color, from the applied paragraph style.) But you can probably do what it sounds like you're wanting to do by using a paragraph style. If less than 50% of a paragraph has a particular direct formatting (i.e., formatting applied without using styles), it will be kept when the paragraph style is applied. (If it's more than 50%, you will have to reapply the colors.) A linked style may work too, but I tend to avoid those (except the built-in linked styles, including Normal and the Heading styles); they usually work fine, but they occasionally do weird things.

It may not be an option, but you may want create character styles for the individual colors you're using; applying a paragraph style shouldn't remove any formatting applied via character styles. (A linked style may or may not remove character styles, depending on how it's applied; one of the weird things linked styles do.)

|improve this answer|||||
0

I had a similar problem. However, I noticed that it didnʼt happen with the built‑in character styles. Opening one of the built‑in styles and then my style in the “Modify Style” dialog box revealed a key difference. Here is an example of the latter:

Font color: Auto

The most important part of this dialog is the read‑only text box near the bottom, which contains a summary of all the changes the style makes. Note that in this example it includes Font color: Auto. Critically, this was not present in built‑in character styles that didnʼt manifest this problem.

Unfortunately, I couldnʼt find any way of removing this through the user interface. I think this is an oversight in the design of Word.

However, there is, at least, a way to do it, albeit not a very user-friendly one. Some time back, Microsoft Office adopted file formats based on XML, so itʼs possible to dissect and arbitrarily modify them directly with relative ease. It turns out itʼs pretty easy to take out the offending colour specification.

I donʼt 100% recall if Word 2010 used the XML format, but I think so. Iʼve tested this in Word 2013; the procedure could be slightly different between versions.

Hereʼs how:

  1. Make sure the file is not open in Office.

  2. Make a backup copy of the file. A mistake in the procedure could render the document unopenable.

  3. Rename the file to have the .zip extension instead of .docx. The Office XML formats are actually just zip files.

  4. Extract the contents of this file into a temporary directory.

  5. Locate a file called styles.xml which will be within a subdirectory called word. Open this file, preferably in an XML editor or a third-party plain text/code editor such as EmEditor. In the worst case you can also use Notepad or Wordpad. Office does not place any line breaks or tabs into the XML, so itʼs going to be a pain to work with unless your editor breaks out the XML elements or at least word wraps.

  6. Find the <w:style> element for the style in question. In my example, the opening tag looks like this, noting that there is a child element for the displayable name, since the programmatic ID canʼt contain certain characters like spaces:

    <w:style w:type="character" w:styleId="IntenseEmphasis"><w:name w:val="Intense Emphasis"/>
    

    Donʼt just go off on the first place you see the styleʼs name, since the name is likely to occur within other parts of the XML as well; make sure it matches the above template.

  7. Find the <w:color> element within that element (it will be somewhere between the <w:style …> and <w:style/>). Programmers note that itʼs inside a child element called <w:rPr>. In my example, the element was as follows:

    <w:color w:val="000000" w:themeColor="text1"/>
    
  8. Delete that whole element (everything from and including the <w:color up to and including the first /> past it). Be careful because the angle brackets for the adjacent tags will be immediately next to this tag, and if you snip off part of another tag, the whole thing becomes unreadable.

  9. Save and close the file.

  10. Zip the contents of the temp directory back up. Note that, if youʼre using the “Send to Compressed (zipped) folder” feature of Windows, make sure youʼre doing this on the contents of the temp directory and not the temp directory itself; Word will not read the file if the internal files are nested an extra level, and youʼll get an error like “Microsoft Office cannot open this file because some parts are missing or invalid.”

  11. Rename the resulting file to *.docx.

You should now see something like this:

No font color attribute

Notice the Font color: Auto is now gone. Assuming itʼs a character style, itʼs now not going to disrupt the colour of whatever itʼs applied overtop of. (I tested on text where the paragraph style had a specific colour, but I assume this would also be true for direct formatting or for a parent character style.)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.