I was able to get ISO burning working just fine in Windows 7, but I'm having trouble with burning regular files (using the built-in Explorer burning functionality). In Vista, I think I selected the files I wanted to burn and just clicked Burn in the toolbar.

However, when I click Burn in Windows 7, it ejects my tray with a "please insert a writeable DVD" message even though I have a blank CDR in there already. Do I need to format it firsT? Vista would detect and offer to format it as part of the process. I don't want a rewritable or open filesystem disc, I'm just trying to burn some .mp3s to CD to play in my car.


I know its not a true solution as it bypasses the problem and isn't native, but have your tried imgburn? I've run into similar hiccups with Windows 7's burning app.

(stupid question but have you tried closing the tray and finding something akin to continue? if the os assumes the drive is empty.)

Yes, it takes some finagling to get the burner to work, under Windows 7, in the native burning app. Try this sequence:

  1. insert cd
  2. wait for Windows 7 to glance at it decide that it's a blank disk
  3. a popup window with three options will appear:
    • use as a live (editable content)
    • 'mastered' (found in desc of second option)
    • cancel (ignore this window)
  4. select mastered.
  5. goto your files.. right click send to > Burner.
  6. goto drive (edit, arange or otherwise)
  7. select burn to disc
  8. edit title
  9. (have an sudden missed beat as you realize that the app stole back your focus while your were typing and have no idea what the next window is: kinda big, blue header, portrait shape. GRUMBLE)
  10. tray ejects

    it works ... not polished or gold plated imho, but... usable.

  • I was really trying to avoid a separate utility..simplicity and all that. I did try closing the tray, different discs, etc, still complained it needed a writable disc. Steps 2-3 didn't apply because I had disabled AutoPlay, but it seems like they may be necessary for it to work..so I re-enabled AutoPlay (and apparently had to reboot, too), and then got the pop-up and everything else worked as it should. Seems like the AutoPlay-initiated "formatting" (setting it as a Mastered disc) is required for the rest of the burning functionality. Annoying.. – Andrew Coleson Sep 5 '09 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.