I'm using Amazon EC2 micro instance with Ubuntu 11.04 on it (official AMI by Canonical). I have created a new security group for this instance:


22 (SSH)
80 (HTTP)
443 (HTTPS)
3306 (MYSQL)
8080 (HTTP*)

But when I start the web server on 8080 and try to open http://ec2-ip-address:8080/ in my browser it says

Server Not Found

… with the standard Google Chrome page.

netstat -anltp | grep "LISTEN" 

says that my only port listened at is 22.

How can I open the listed ports so I can start my web projects?

EDIT: The solution has been found. All you need is to start server at IP address, not or localhost.

  • This solved my problem as well using Google App Eninge on EC2. Have to start it using dev_appserver.py --host= to be able to connect from outside.
    – A.W.
    Jun 18, 2014 at 8:43

1 Answer 1


There are a few possibilities here. First possibility is that you haven't set that port up as a listener in Apache, you can do this by adding a line like

Listen 8080

Into you Apache configuration file.

The second possibility is that UFW is running (ubuntu Firewall), you can disable this by running

sudo ufw disable

or add ports to it via

sudo ufw allow 8080

The last possibility is IPTables is blocking it, you would need to look at

sudo iptables -L

to get a list of rules and change them from there.

  • I'm not using Apache, disabled ufw and clear all iptables
    – bbrodriges
    Dec 2, 2011 at 9:28
  • OK, Sorry, I assumed you were using apache, it seems like whatever is supposed to be listening on port 8080/80/443 etc is not configured/started. What webserver are you using, perhaps I can help with that.
    – Kevin
    Dec 3, 2011 at 3:22
  • I'm using standard webserver which comes with CherryPy Python web framework.
    – bbrodriges
    Dec 5, 2011 at 13:49
  • Yes, so that is not starting up, or running. You will have to look into how to start the webserver that comes with CherryPy, as I am not familiar with that.
    – Kevin
    Dec 6, 2011 at 2:23
  • After looking around 1000 blogs and bla bla I found this as working solution for me. Thanks bro from soul of my heart Nov 10, 2020 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.