21

The box-like cursor in Linux Mints terminal (and ubuntus) is really confusing me! I am used to a vertical line so it's hard for me to focus on the commands when I am unsure where this box-ish cursor really is all the time.

Is there a way to change this? Thanks!

2
  • I looked around prior to posting here but couldn't find anything of use...
    – Daggepagge
    Commented Oct 29, 2011 at 0:07
  • Allright! I understand. Is there a way I can move this to a better place? Or should I just remove it? If so, how? Thanks!
    – Daggepagge
    Commented Oct 30, 2011 at 22:55

4 Answers 4

12

This is a function of the Terminal program itself.

In Ubuntu, if you're using terminal you can change this in the terminal application preferences, which is accessible from the terminal application menu in the Ubuntu status bar in the top left of the screen.

Terminal Menu
  -> Preferences
    -> Profile
      -> Cursor
        -> Cursor Shape
          -> I-beam

There's a pull-down menu for "Cursor Shape" and "I beam" is an option.

4
  • 1
    This is an off-topic question. You should be voting to migrate it instead of answering it. :)
    – Ken White
    Commented Oct 29, 2011 at 0:15
  • Brian, do you know if you CAN progamatically change this? For example, if I set -o vi and press escape, i am not using VI-style keystrokes. I'd like to change this to a box. Can you do this somehow?
    – ddavison
    Commented Feb 24, 2014 at 19:03
  • "I am now using vi-style keystrokes"
    – ddavison
    Commented Feb 24, 2014 at 19:17
  • Actually, this settings has moved to a Profile's settings and there to the "Text" tab now.
    – sschuberth
    Commented Feb 19, 2020 at 10:08
21

At the time the question was asked (October 2011), the way to do this with the given terminal was via its preferences dialog. After a few years (November 2014), someone added support for the DECSUSR escape sequence which was used (and extended) in xterm since December 2009.

The change mentions these choices:

+        VTE_CURSOR_STYLE_TERMINAL_DEFAULT = 0,
+        VTE_CURSOR_STYLE_BLINK_BLOCK      = 1,
+        VTE_CURSOR_STYLE_STEADY_BLOCK     = 2,
+        VTE_CURSOR_STYLE_BLINK_UNDERLINE  = 3,
+        VTE_CURSOR_STYLE_STEADY_UNDERLINE = 4,
+        /* *_IBEAM are xterm extensions */
+        VTE_CURSOR_STYLE_BLINK_IBEAM      = 5,
+        VTE_CURSOR_STYLE_STEADY_IBEAM     = 6
+} VteCursorStyle;

The feature is documented in XTerm Control Sequences:

CSI Ps SP q
          Set cursor style (DECSCUSR, VT520).
            Ps = 0  -> blinking block.
            Ps = 1  -> blinking block (default).
            Ps = 2  -> steady block.
            Ps = 3  -> blinking underline.
            Ps = 4  -> steady underline.
            Ps = 5  -> blinking bar (xterm).
            Ps = 6  -> steady bar (xterm).

so that you could (for example) do this on the command-line to change the cursor to a bar ("I-beam"):

printf '\033[6 q'

(the space is needed, corresponds to "SP" in the documentation).

3
  • Thanks for this reference. This is really great and the answer I was looking for!
    – Puhlze
    Commented Jun 6, 2021 at 6:36
  • Can I make this state permanent? It resets to it's default every time I reboot the system (I'm using WSL). Commented Jun 28, 2023 at 7:02
  • For xterm, that would be resource-settings, for most terminals, in the shell login initialization, but for (gnome) terminal, there's neither documentation nor preference settings that apply consistently. Commented Jun 28, 2023 at 8:07
1

In Bodhi 2.4.0 you can disable the blinking cursor ( less hindrance) : right-click empty space in terminal-window -> Settings ->Behaviour -> uncheck Blinking Cursor

0

In ubuntu Terminal window,right click on Terminal empty space.profiles>profile preferences>cursor shape>I-Beam

1
  • 1
    How is this better than other answer?
    – Toto
    Commented Mar 11, 2018 at 18:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .