Notice: I have now rebuilt my machine to remove this bug, so I can no longer verify any answers.

I recently installed Internet Explorer 9, and activated the development tools by pressing F12; I then clicked "script" and the "start debugging" button but I got the following error:

Unable to attach to the process. Another debugger might be attached to the process.

I get this message regardless of the site I am on (currently I'm on google.com). I have no other applications running, and have rebooted my machine.

Can anyone suggest why this may be appearing?


I've had this same issue in the past and a third-party extension was the cause. I fixed this by opening up Internet options from the Tools menu within IE9, going to the Advanced tab and unchecking, Enable third-party browser extensions. You'll need to restart IE9 for the change to take effect.

|improve this answer|||||
  • I hadn't tried that. I've done it now, but no effect. Sorry. – Urbycoz Nov 28 '11 at 8:58

If you are using a Windows x64 version, this might be a bitness mismatch that is causing the problem.

Could you please specify your exact Windows version and that of IE9 ?
(On 64-bit Windows, Task Manager will show "*32" near to 32-bit processes)


Since this is not the problem, could you try creating in the following registry key :
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
a DWORD value called TabProcGrowth and assign it the value of 0.

As explained in Seven Things You Should Known About IE 8, tip #4 :

TabProcGrowth = 0 - a value of zero means use the same process for all tabs, frames and pop-up windows in each browser session.

So this may avoid the need for process attaching and may let you debug the site.

You might also, as a test, try to Turn Off UAC in Windows 7.

|improve this answer|||||
  • See my edit above. – harrymc Nov 28 '11 at 11:00
  • Thanks. I've tried creating that key in the registry, but I still get the same error message. I've also turned off UAC, but no effect. Sorry. – Urbycoz Nov 28 '11 at 11:35
  • 2
    Something is wrong, and is probably related to permissions, but it is hard to guess what has changed on your computer. If you have a Windows 7 installation DVD with same service pack as installed and with IE9, then you could use sfc /scannow to verify your system. If you need to slipstream, see for example this article. – harrymc Nov 28 '11 at 12:49

Do you have the Debug Programs privilege? You may need to be running as Administrator (right click -> Run As Administrator) to get a user token that has this permission.

|improve this answer|||||
  • Just tried running as administrator. Problem persists. – Urbycoz Nov 28 '11 at 9:37
  • And you have the debug programs privilege? – ta.speot.is Nov 28 '11 at 12:10
  • I think so. How can I check? – Urbycoz Nov 28 '11 at 14:32
  • Check that you're a member of a group in this list. (Loosely) taken from answers.microsoft.com/en-us/windows/forum/… "1. Type "secpol.msc" into Run 2. Clicking the "Local policies" item. 3. Select the "User Rights Assignment" item. 4. Double-click the "Debug programs" option in the right panel. 5. Click "Add user or group..." button. 6. Insert the user name and click "Check names" button. 7. Click the OK button and close all opened windows. 8. You have to restart your session." – ta.speot.is Nov 28 '11 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.