I want to mount a USB drive, two of them and I need two different mount points. Unfortunately, the Linux kernel underwent a name change and I can't figure out which /dev location is the right one. Is there a way to look through dmesg or /proc or somewhere else to find out which device node is a USB drive.

(I'm using ArchLinux if that helps any.../dev/sda is the first hard drive, /dev/sr0 is a dvd drive, etc.)

edit: The USB drive is connected to a USB hub. I looked through dmesg and it says the hub was connected and it scanned for the 3 devices connected to it. Still can't see where my USB drive is though.

  • 1
    Can't see it? Maybe wait for a bit. Or try another USB port. See what differences there is in 'lsusb' Mar 10, 2009 at 23:02
  • Might want to rephrase the question somewhat - not all usb devices are disks, after all.
    – Arafangion
    Mar 10, 2009 at 23:23
  • 3
    The df command shows you where it was mounted Aug 28, 2013 at 14:09

13 Answers 13


Easiest way: Look at the output of dmesg after connecting the USB device. It should show you what /dev node was assigned to it.

  • 8
    dmesg works great, but I have a case where dmesg does not show the /dev node: [421963.864281] usb 3-6: new high-speed USB device number 32 using xhci_hcd What does this mean? How can I mount this device? The device shows up on lsusb...
    – modulitos
    Apr 25, 2016 at 5:58
  • 1
    Actually, I figured it out. There was a kernel update since my last reboot that was causing this problem. After a reboot, my usb mounts just fine. Hopefully this helps someone!
    – modulitos
    Apr 25, 2016 at 6:39

All of these are good suggestions, but the quickest and least verbose method is to just type the following in the terminal:


which will give a list of all the mounted devices (this assumes the USB drive is mounted, which is usually the case with modern Linux distros).

  • 7
    No, it doesn't magically mount your device. You have to specify it with mount /dev/id /mount/point, so that doesn't work.
    – polym
    Jul 22, 2014 at 14:02
  • 12
    My answer addresses the user's question 'Is there a way to look through dmesg or /proc or somewhere else to find out which device node is a USB drive.', and is not intended to provide guidance on the practicality of mounting a drive under Linux. Jul 23, 2014 at 14:43
  • This answer solved an almost identical question for me. Oct 10, 2014 at 11:04
  • 2
    I think automount behavior depends alot on the distro type.
    – jiggunjer
    Feb 2, 2016 at 2:08
  • 2
    df too, i suppose.
    – Alexey
    May 26, 2016 at 16:11

As long as you are running udev, you can do this easily by referencing /dev/disk/by-id/usb-manufacturername_serialnumber. These appear as symbolic links which you can either directly reference within your fstab, or which you can dereference using readlink -e to determine the associated block device.

Here's a real world example. On my machine, I have 3 USB hard drives connected. These each show up in /dev/disk/by-id with unique serial numbers (although they share a common manufacturer string). I have created symbolic links to each of these three unique entries, and can now quickly determine which drive is which (and which device is associated with each drive) by running readlink -e linkname. For example, running readlink -e /root/disk2 on my machine currently displays "/dev/sde", while readlink -e /root/disk3 produces no output whatsoever.

  • 17
    Short and simply: for devlink in /dev/disk/by-id/usb*; do readlink -f ${devlink}; done Nov 25, 2015 at 14:02

Try the command udevinfo -q all -n /dev/sda, where /dev/sda is the path to your disk. This gives you a boatload of info about the disk you're looking at - there's an entry that tells you about the bus it's connected to.

This of course saves you from having to grep through dmesg and/or logs.


udevadm info --query=all -n /dev/sda 

From at least Jul 2010 [1] udevinfo was substituted in Debian (and derived) by udevadm info with a little transient with which there were symlinks soon deprecated and removed (you can still found them in old not updated machine). Always from [1] we can read:

In udev 117, udevadm was introduced and udevinfo and other programs turned into compatibility symlinks. The symlinks were deprecated in udev 128 and removed for good in udev 147.

  • 8
    In Debian, udevinfo is renamed udevadm. Aug 23, 2011 at 14:44
  • 8
    On Ubuntu, the command seems to be "udevadm info --query=all -n /dev/sda" Dec 13, 2011 at 6:06
  • I suppose they renamed the command at some point - when I wrote the answer (ages ago) the command worked on the ubuntu system that I posted it from ;)
    – Eltariel
    Dec 15, 2011 at 5:08
  • Command works still in ubuntu, udevadm info --query=all -n /dev/ttyUSB1
    – Siddharth
    Jun 4, 2013 at 8:43
  • 1
    udevadm info --query=all -n /dev/ttyUSB in Fedora too.
    – slm
    Oct 26, 2013 at 14:50

the simplest method to see what's going on is just typing (as root of course):

blkid -c /dev/null

this gives you a complete overview about all block devices even if not mounted

  • Not all distro have this. Which were you using? Sep 19, 2015 at 17:26
  • This outputs nothing on my Raspbian distro. Aug 8, 2016 at 6:17
  • Command not found: blkid Sep 28, 2016 at 17:13
  • No output from this command on Ubuntu 14.04 64-bit.
    – gbmhunter
    Apr 17, 2017 at 18:15
sudo fdisk -l

And just analyse the result.

  • 1
    fdisk man page "If no devices are given, those mentioned in /proc/partitions (if that exists) are used." Running fdisk may not be an option... Based on one Debian system that I know doesn't have it installed, my guess is that some GPT systems might not install the unneeded software. Still, checking /proc/partitions ought to be an option.
    – TOOGAM
    Nov 10, 2015 at 7:33
  • This was the only option that worked fine for me. I am sorry if it didn't work for you!
    – Felipe
    Nov 10, 2015 at 21:52

/dev/disk/by-* is the easiest way in this case, if for some reason you want to make life more interesting you can use HAL.

To list all devices you use:


To get a specific property you use (this will return /dev/sd* on a USB storage device):

hal-get-property --udi $UDI --key block.device

There is also:


If you want to make it even more complicated you can relatively easy write yourself a HAL based auto mounter, which can be quite handy if you want to automate things completly.

And just for completeness there are also:

lsusb -v

Which provides some general information about USB and your hardware in general.

  • 3
    /dev/disk/by-id/*usb* is very helpful.
    – Rob
    Dec 12, 2011 at 18:56
  • /dev/disk/by-label ftw. Thanks :) Jun 17, 2013 at 13:25


ls -l /dev/disk/by-id/usb*

Under the default udev rules, that will show you most usb devices and it will show you the symlink to their block-device name on the system.

If that doesn't work, look at /dev/disk/by-id/ directly.


For USB devices you can simply do

for _device in /sys/block/*/device; do
    if echo $(readlink -f "$_device")|egrep -q "usb"; then
        _disk=$(echo "$_device" | cut -f4 -d/)
echo Removable drives found: "$REMOVABLE_DRIVES"
  • 1
    +1. Simple and concise script to do the task automatically.
    – leesei
    Nov 18, 2015 at 14:28

Take a look at the tree under /dev/disk. It lists disks and their partitions (file systems) by various schemes.


/var/log/message if dmesg no longer has the information.


If you unplug the USB drive and plug it back in, you should see it initialize from the kernel (dmesg)


Based on the excellent answer from stormlash and with a dependency on udev to populate the "/dev/disk/by-id/usb" device tree, you could define a predicate (Bash) as follows:

is_usb_device() {
    local device_path=$1        # such as /dev/sdc
    for devlink in /dev/disk/by-id/usb*; do
        if [ "$(readlink -f "$devlink")" = "$device_path" ]; then
            return 0
    return 1

And then use it:

if is_usb_device "/dev/sdg"; then
    echo "/dev/sdg is a usb device"
    echo "/dev/sdg is not a usb device"

You must log in to answer this question.