• Recently built my own PC. It works! Almost.
  • It's been a while since getting into the guts of these things, so I'm familiar but may be missing something simple.
  • FYI, I don't care about blowing the OS away -- it's brand new and we can go back from scratch as many times as necessary.

Goal / Issue

  • I'd like to use the SSD to take advantage of Intel's Smart Response technology (allows the SSD to act as a cache for HDDs)
  • I would like the SSD cache to act as a cache for my HDDs, which I would like to be in a RAID1 array (so I get the speed from the SSD and the redundancy from the RAID1)
  • However, Windows only sees the drive in device manager (not as a drive), so I'm unsure what to do about that.
  • Related: as far as I know, for this to work, the drives all have to be in a single RAID array (i.e. a RAID0 pairing of the SSD and the RAID1 HDD array).
    • However, when attempting this at the BIOS level, I am told there is not enough space for an array.

Steps so Far

  • Moved the SSD onto the Intel controller (I'd had it on the Marvel 6.0 controller instead of the Intel controller, so the BIOS was only seeing it in a strange way)
  • Updated the BIOS of the motherboard to the latest version
  • Reinstalled Intel's RST (iRST?) software several times, as some forums reported it working after reinstalling 3 times (which does not inspire confidence).
  • Checked Intel storage: it does see the SSD as a physical, non-RAID device. However, it says no space exists if I try to create an array.
  • Checked the BIOS: it does not show up in the boot order, but is an option that can be selected under boot options.
  • Tried the firmware update for that model. Issue: the firmware CD doesn't detect a drive; maybe the Intel storage controller is making it difficult?
  • moved the ssd to the marvel controller. The firmware update cd appeared to hang while searching for drives.
  • swapped out the SATA cable for the manufacturer's and moved back to the intel storage controller.
  • Noticed at this point that in the Intel RST software, a device DOES show up in addition to the RAID set -- only shown as a "60 GB internal disk". Windows doesn't appear to see it as a drive, but it does still show in device manager.
  • Move SSD to port from 0-3 on MOBO and set SATA mode to IDE (after disconnecting RAID1 config) to allow the firmware update to work. Firmware was already at the latest version.

Next Steps

  • ?

Components involved

  • ASUS P8Z68-V PRO motherboard (Intel Z68 Chipset)
  • Intel i7 2600k Processor
  • 2 x 1TB 7200 RPM HDDs
  • 64 GB Crucial M4 SSD (M4-CT064M4SSD2)

For Reference -- Storage Configuration

Intel 3 gbps   Intel 3gbps   Intel 6gbps   Marvel 6gbps
+----------+   +----------+  +----------+  +----------+
|          | <----+       |  | +-+      |  |          |
|----------| | |----------|  |-|--------|  |----------|
|          | | |  +       |  | |        |  |          |
+----------+ | +--|-------+  +-|--------+  +----------+
             |    |            |
             +    v            v
             |   1 TB HDD     64 GB SSD
             +> 1 TB HDD

For Reference -- Intel RST (v10.8.0.1003) Screenshot

Don't mind the "rebuilding" -- knocked a power cable out at one point; it's doing its job, not an indicator of a bad HDD.

Intel RST Screenshot

Any thoughts? Thanks in advance for any help!

2 Answers 2


Where did you get the Rapid Storage Technology software from? You're best bet is to download it directly from Intel. I have the same Motherboard as you and have a very similar configuration. I am Raid0 of 2x500GB 7200RPM drives. I installed the system with my SSD unplugged from the Motherboard and installed Windows 7 normally. Once I got the system up and running, I installed all of the motherboard drivers. Once confirming that the system is fully installed (no unknown devices in the Device Manager) I shut down the computer and plugged in the SSD. After it rebooted, I launched RST and clicked on the Accelerate tab. I clicked on a button that would enable the acceleration and selected my Raid0 Array. It then asked me to select the SSD and how much of the space to use. I have a 128GB SSD which will allow me to use up to 64GB. I am able to partition the rest of the space as a separate drive/partition.


With a new solid state drive and srt, make sure that you also have a partition created on the SSD prior to enabling the SRT

enter image description here

  • Hi kobaltz, thanks for the reply! I downloaded the software directly from Intel (v10.8.0.1003 -- the latest version I think?) However, I do not even see the "Accelerate" tab on the software. I only see "status", "manage", "preferences", and "help". This is why I think the SSD is not being recognized correctly. Nov 27, 2011 at 15:23
  • do you have any partitions on the SSD? Also, is the SSD plugged into the SATA6 port?
    – kobaltz
    Nov 27, 2011 at 16:05
  • Per the reference diagram, the SSD is plugged into the sata6 intel port, not the sata6 marvel port. The two 1TB drives are in sata3 intel. I've never touched the SSD other than to take it out and plug it in; windows sees it as a device but doesn't even list it as a non-formatted drive to allow me to format it. Nov 27, 2011 at 16:19
  • try making a partition of the SSD in the Disk Management. See if that kicks in anything.
    – kobaltz
    Nov 27, 2011 at 17:21
  • Will do and will get back to you; another option I tried killed the raid1 array so I have to rebuild windows first :) Nov 27, 2011 at 17:23

The solution, as suggested by @kobaltz, lied in the fact that I'd trusted the SRT solution to find the disk drive itself and create a partition.

Once I created the partition on the SSD, the IRST software found it normally and the "Accelerate" menu option gave me the choices I needed.

I'm still having an issue, but it seems to clearly be a separate issue and so I'll open another thread.

[Note: @kobaltz, if you want to rephrase your comment as an answer, I'll give you the credit. Thanks!]

  • Glad to hear that you were able to get it working!
    – kobaltz
    Nov 28, 2011 at 4:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .