My latest display driver doesn't support WDDM 1.0, and I need it to be at least version 1.1.

I've been attempting to get the Windows Phone 7 SDK working on my HP Pavillion dv9000, but the phone emulator requires 1.1 or higher. My drivers are as up-to-date as they can get. I even tried a modded driver found here, but no go.

Then, while evaluating Windows 8 Developer Preview on a different partition I noticed that dxdiag.exe showed it was using WDDM 1.2. I tried installing Windows Phone 7 SDK on Windows 8, but I get an "Internal Error" popup and "Connection failed because of invalid command-line arguments" in the error window in Visual Studio. I'm guessing because Windows Phone 7 SDK isn't supported on Windows 8 yet.

So my question is this: Can I get Windows 7 to use the display driver Windows 8 is using to get WDDM 1.2 on Windows 7 and how would I go about doing it?


Windows 8 uses Hyper-V technology for virtualization, which is not compatible with the current Windows Phone development tools. There are a couple of possible options if you really have to work in a virtual machine on Windows 8:

  1. Uninstall Hyper-V from Windows 8.
  2. Create a 32-bit Windows 8 Hyper-V image on Windows 8.

If you're only evaluating Windows 8, then option 1 is likely to be the better option. If you need Hyper-V, then option 2 will work, but it's going to be quite slow (as is any kind of development inside the virtual machine).

For more information/detail, take a look at this blog post: http://wp.me/p1OzDh-5w

  • Are you assuming I'm running Windows 8 in a virtual machine on Windows 7 or that I installed Windows 7 using this "Hyper-V" inside Windows 8? I'm running no virtual machine. The two OS's are on separate partitions of my hard drive. – adam0101 Nov 28 '11 at 18:39
  • Also, Hyper-V is not checked in the Windows Features window, so it looks like it's already uninstalled. – adam0101 Nov 28 '11 at 19:24
  • It's grayed out, not because it is already uninstalled, but rather because your hardware isn't compatible. Hyper-V install is an option, even after the OS has been installed. – surfasb Nov 29 '11 at 18:32
  • I didn't say it was grayed out. It's unchecked. – adam0101 Nov 29 '11 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.