4

How do I reboot a machine on a Remote Desktop connection after explorer.exe crashes?

I'm stuck at trying to do this. After I googled a bit and found that people were saying to use Ctrl + Alt + Esc or Ctrl + Alt + Del to turn on the Task Manager. Both didn't work. So now all I have is a blank desktop and no key combination can work at all.

How do I either show Task Manager so I can start a new instance of explorer.exe or how do I restart the machine via keyboard shortcuts?

4

if you are using Windows Remote Desktop Connection,

  1. Before you hit connect, click the options drop-down,
  2. Go to the Programs tab,
  3. Check the box that says "Start the Following program on Connection"
  4. Enter 'explorer' (without quotes) into the Program Path and File Name Box
  5. Connect Normally

I've had a similar issue with one of our work VM instances and it's a pain to have to get I.T. to reboot it all the time, and I couldn't seem to open Task Manager when the instance was in this state.

  • i tried nothing happen – Ishan Shah Oct 5 '17 at 7:13
  • @Ishan - sorry to hear that, it might actually be locked up. Have you tried the 'Ctrl Alt End' option in Ben Richards' answer below? – Robotnik Oct 5 '17 at 10:41
6

What you need to use is Ctrl+Alt+End and that will let you get to the task manager. Then, click on File -> New Task (Run...) and type in explorer.exe and press Ok. Explorer will start back up and you should be able to continue working as before. If you really want to reboot at this point (though it usually isn't necessary), you can do so by clicking Start and typing command prompt and pressing Enter, to get the command prompt window open. Then type in shutdown /r and press Enter and that will reboot your computer after a short time delay.

0

Depending on what software do you use to remote into the machine (Windows Remote Terminal, VNC, etc.) these applications provide the option of signaling the remote machine to reboot. Search your client's menus.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.