I built my computer about 3 months ago. It has a Seagate Barracuda 7200.12 1TB HDD (model ST31000524AS) on an AsRock 970 Extreme Mobo. My HDD was split into 3 partitions, a partition for windows 7 ultimate 64bit, a partition for ubunu 11.04, and a partition I use to store files. Last night I went to bed while my brother was playing Skyrim on my computer. He said there were no problems when he went to bed last night, but when I woke up this morning, I received the POST message "Reboot and Select proper Boot Device or Insert Bootable media in selected boot device and press a key". I tried switching both the power and sata connections on my CD drive, which still works., and that made no difference. I have no devices except for my monitor plugged in. What's more is that in the UEFI, it doesn't even show my HDD, and when i try to run windows 7 repair with the installation disk I have, there are no Operating Systems, partitions, or any other things to be repaired.

EIDT: After running seatools for dos off a cd, it instantly failed the tests because it could not access the drive. I had a friend put it in his rig and got the same results.

marked as duplicate by bwDraco, fixer1234, music2myear, Pimp Juice IT, G-Man Jun 18 '17 at 4:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Your HD sounds busted – soandos Nov 29 '11 at 7:11

I would suggest getting one of those USB-adapters for hard drives. With that you just remove the HDD, plug it in the usb in another computer and then you can see if the HDD works. If it works you should probably return your motherboard. If it doesn't... buy a new drive, they're not that expensive.

Sorry to hear your loss though.


If its not detected in bios/UEFI, and swapping and rechecking power and data leads dosen't help, chances are its a goner. Its new enough to RMA, so i hope you made backups, cause the best option is to get it replaced..

I disagree that its the motherboard, it wouldn't boot at all and you'd have issues other than a hard drive going AWOL

I've had a similar issue with another seagate, and they replaced it, even tho i was unable to run seatools on it.

  • I've had problems with the SATA-controller that only showed itself with the HDDs connected to the ports on that controller.. the rest of the motherboard worked okay, it could even boot live ubuntu! – Phil Nov 29 '11 at 12:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.