12

This question already has an answer here:

After (hopefully) scrubbing viruses out of a Windows 7 installation (after deciding not to simply run over the laptop repeatedly with my car), I've got everything almost back to normal. The only lingering issue I have is that for my non-admin users, the ".exe" file extension doesn't work. That is, clicking on the various desktop application links results in a "How do you want to open this?" dialog.

I've been through the alleged registry fixing from "winhelponline" and that had absolutely no effect. I've tried running "assoc" for the affected users, but it reports the .exe association to be "exefile" even though it persistently does not work.

Right-clicking on a desktop icon and then choosing "start" does successfully open an application, but that's clearly a terrible situation.

For my admin user, things seem to work fine.

What do I need to do to get things working?

marked as duplicate by Ƭᴇcʜιᴇ007 windows-7 Jan 20 '17 at 16:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I assume that you restarted after making regisry changes? – soandos Nov 30 '11 at 1:11
  • 1
    Yes, it being Windows I've restarted about 800 times :-) – Pointy Nov 30 '11 at 1:28
  • 1
    I'm voting to close this question as a dupe of this other question because the other question has better answers, even though this one was posted earlier. This dupe network is being discussed on Meta. – Ben N Jan 25 '16 at 16:56
6

Open Notepad and save a text file (using a .reg extension) with the following content:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"

Double click the file then reboot.

DISCLAIMER: Use at your OWN risk! There is no guarantee that this will work!

  • 1
    I've done exactly this. It had absolutely no effect. (edit at least I think that's what one of the random .bat files that purported to fix it did. I can try it however. Can you tell me what that would look like from within regedit?) – Pointy Nov 30 '11 at 1:38
  • Also, what's the explanation for things working fine for my admin user, but not for non-admins? – Pointy Nov 30 '11 at 1:40
  • When viewing the registry, under the path given, you would see a text value of: "%1" %* – Myrddin Emrys Nov 30 '11 at 1:45
  • 4
    Well, it has to be a .reg file, not a bat file. Was it a reg file you ran? And as for admins, the [virus] thing might have edited your registry in only HKEY_LOCAL_USER section. If you use HKEY_CLASSES_ROOT, then the changes are global. – itdoesntwork Nov 30 '11 at 1:48
  • OK I probably tried a .reg file. I'll definitely try this however. I can't at the moment because my kid is currently using it via the Linux partition :-) – Pointy Nov 30 '11 at 2:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.