I have a dual boot system in place, Ubuntu/Windows, each on its on physical hard drive since I also have SRT active on the Windows partition.

The setup is as follows:

Disk 1:
- Partition 1: System (Windows 7)
- Partition 2: Storage (NTFS)
Disk 2:
- Partition: Ubuntu

Now, I can easily mount the Windows partitions from Ubuntu and read their files. I can even copy the files onto the partition in question (Storage - Disk1/Partition2), and it works flawlessly. However, I cannot see ANY files added by Ubuntu when I boot Windows up. So basically, Windows only sees its own files on the partition, while Ubuntu sees everything.

Is there something I need to do to make Windows see Ubuntu-made files? Keep in mind that the partition is NTFS, not ext2/3/4, so Windows does see it - just not the files which Ubuntu makes (and Win7 doesn't even take those files into account when calculating leftover free space on said partition - they are completely nonexistant to the OS)

My goal is, essentially, to have one Storage partition through which both Operating Systems could share files - thus having music, movies, code samples and downloads all in one place, accessible and changeable by both OS - without having to resort to something like a physically separate network drive.

Edit: Curiously, the changes I do on Ubuntu to existing Windows files are not carried over either. I just made a text document in Win7, and then edited it in ubuntu. Booting in Ubuntu shows the changes, while booting in Windows shows me the file's previous state. How curious.

Found the solution, answered below, will accept as soon as possible.

  • 2
    Windows ought to be able to see the files, even though they were added by Ubuntu, without any intervention. Run chkdsk from Windows to make sure the NTFS partition isn't damaged in some way. Nov 30, 2011 at 18:59
  • No errors were found after running checkdisk. I just tried copying a folder with a text document from Ubuntu's Documents to this Storage partition, and I can once again confirm the issue - there is no sign of the folder or its document. All is well if I reboot into Ubuntu again, though - the file, and other Windows-made files, are there and accessible.
    – Swader
    Nov 30, 2011 at 21:33
  • Please expand the acronym SRT.
    – kreemoweet
    Nov 30, 2011 at 22:53
  • Updated my answer
    – Swader
    Nov 30, 2011 at 23:07

3 Answers 3


The reason was the SRT caching.

I had it turned on to speed up my Win partition for gaming mostly, and since my caching SSD was 64GB big (current maximum size for SRT) it basically cached everything it got its hands on since it hadn't run out of space yet to start purging. As such, all Windows could see was the cached content, pulled from the SSD, while Ubuntu (since there is no SRT support for it) saw the up-to-date state.

Once I turned SRT off and rebooted to purge the cache manually, they communicate with the partition flawlessly. Naturally, this is unacceptable because I need my SRT on the Win OS, so I'll just plug in a new drive to serve as the share disk. That way I have some redundancy as well.

Thanks for the help everyone!

Edit: As per request, some information on SRT: http://en.wikipedia.org/wiki/Smart_Response_Technology Basically, it's a caching mechanism which uses an entry level SSD to learn which files you use the most, and then uses the SSD to load them instead of loading them from the HDD. This is only supported in Windows for now, and provides SSD performance with large HDDs - huge capacities at the speed of SSD for the vast majority of your regularly used files

For example, my Windows boot time went from 24 seconds to 15 seconds, while loading a large level in Skyrim at max detail takes around 1-2 seconds. Not sure how useful these comparisons are to the Superuser userbase, but here they are :)

You can read more about it by just googling Intel SRT - there are plenty of reviews and benchmarks out there.


You should be able to share the files from Windows<=>Linux as you wish using an NTFS partition

  1. Ensure that you have explorer set to show all system and hidden files
  2. Note that Windows and Linux have a different set of users (even if they have the same textual name e.g. both are joe) hence you may run into permission problems, but I would expect in that case you could see the files but not read them.

See man mount.ntfs for info on NTFS mount options. I think the permissions and inherit options might be useful for you. To see the current options try mount | grep ntfs

  • 1. Tried - I can see System Volume Information and Recycle Bin folder, as well as the windows-made files, but no Ubuntu-made files. It is as if there is nothing at all from Ubuntu on that partition.
    – Swader
    Nov 30, 2011 at 21:29

Is your Windows in a hibernated/hybrid sleep state? If so, you cannot write to any NTFS partition still mounted/open in Windows (which would normally be the case). You must either unmount the partition in Windows before hibernating/sleeping or do a full shutdown.

  • Nope - I do a full restart on every OS boot.
    – Swader
    Nov 30, 2011 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.