I have a D-Link (DIR-655) wireless router connected to Time Warner Cable internet. Frequently, the internet connection stops working on all devices, though I can still connect to the router itself. The lights on the modem show that the internet is working, and the wires are all connected correctly. Often, the internet can be restored by resetting the wireless router and waiting a minute. I recently updated the firmware on the router, but that doesn't appear to have helped.

What is going on and how can it be fixed? Thanks!

  • Have you confirmed this is an issue with the dlink and not with TWC? – Paul Nov 30 '11 at 22:53
  • Are you using power over ethernet? Sometimes the power quality is poor using POE, which can cause problems. – steampowered Nov 30 '11 at 23:11
  • normally, the modem's lights are still on, and when I directly plug a laptop into the modem (and reset the modem) it connects, while the router still doesn't work. – Ari Nov 30 '11 at 23:28
  • its plugged into a regular power strip. – Ari Nov 30 '11 at 23:29

I have a D-Link and have had similar issues. Once in a while (used to be once a week on average) the router would suffer a crash in its wireless stack. This can be easily verified: you cannot browse to the router's admin site - it's down. But if you connect a laptop to an ethernet plug on the router, you can surf.

If you look at the D-Link forums for the 655 and 825 models, you'll find dozens of complaints. D-Link ignored this for several months and the started to try addressing it by a series of firmwares. In the case of the 825 they even came out with a B-model that fixes most problems (not that it helped anyone who had the A already).

The latest release seems to do the trick for me: I now average about a month between crashes. What seems to exacerbate the crashes is downloading large quantities of data, particularly if you use BitTorrent. The higher the download speed, the higher the chance of a failure.

So, upgrade to the latest firmware, avoid going over 500Mb/s downloads and you should be fine. Alternatively, do what other people on the forums suggest and ditch the D-Link.

  • I have the same router and I agree: ditch the D-Link if you want to stop this happening. They're cheaper than the other guys for a reason. – user3463 Nov 30 '11 at 23:04
  • "But if you connect a laptop to an ethernet plug on the router" Do you mean directly to the modem? – Ari Nov 30 '11 at 23:25
  • I'm actually still able to connect to the router. It seems to be a problem in the router handling its connection to the internet. – Ari Dec 1 '11 at 17:09
  • I meant connecting your laptop to the router - not the modem. Connecting to the modem will verify whether the problem is with your ISP. Connecting to the router would verify a) the router b) the wireless stack – Traveling Tech Guy Dec 1 '11 at 18:07
  • "upgrade to the latest firmware," Can you please provide a link in your answer? – Kalamalka Kid Dec 17 '17 at 7:05

This could be many things. One common cause is bad power to the modem and router. A small brownout/spike sends a device into an unusual state. Have seen this at a number of client sites. Add a UPS and all is well.

Naturally, there could be other external factors with your connection. I have D-link on a UPS and am having issues with bad IP addreses.

Just found a note that the seting on the WAN port is configured to Auto speed as default. Several users report setting it to a fixed speed (10Mbps in my case) to match the modem resolved the constant disconnects. Tried last night and it is stable so far ( about 12 hours) I have seen speed/duplex issues with some enterprise Cisco hardware as well. Changed to fixed speed and duplex and problem solved.


Some D-Link routers have a "bug" in their internal software, namely that the internal clock cannot be set to 1/1/2013, or any later date. Instead, the router sets itself to the correct month & day, but to the year '2002'. So, while the router obtains an IP-address from the Internet Service Provider, it waits for half of 12 years (2014 [the current year] minus 2002) before trying to "renew" the DHCP-supplied IP-address. So, the lease "expires" without being renewed, and the ISP severs the Internet connection. If the router is powered-off/powered-on, it obtains a new lease, and, voila, the Internet connection is restored, until the next time that the ISP again severs the connection.


Check to see if the correct MTU value is set. In some cases (my own case) a higher MTU value caused problems. Generally its set at 1500 at default. That might correct your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.