I've been mucking around with the partitions on my laptop (I'm an experienced Linux/grub guy) and have somehow ended up affecting the ability of Windows 7 to go into hibernate mode. All other functionality seems to be okay. But when I press Hibernate, it behaves as if it starts to (screen goes dark, a little disk activity) but never powers off and if I move the mouse the login screen instantly comes up.

I don't know if Window uses a separate partition for hibernation? There is a 200MB partition on the drive - I seem to recall it was related to diagnostics or some other Windows- boot menu stuff.

In any case, wondering if there's some commands I can run to restore the ability to hibernate and also which partitions need to be marked "active" and if there's anything I need to do to the MBR of the hard drive or the MBR of the Windows partition?

As I said, Windows boots fine as long as it is designated the Active partition. I just need to fix Hibernation.

  • Windows uses a file called Hiberfil.sys for hibernation which according to the answer to this question, cannot be moved (see the quote and the linked article in that answer for an explanation as to why that's the case). So first up, I'd check to make sure the Hiberfil.sys file is actually present. – John H Dec 1 '11 at 1:57
  • 3
    Actually, maybe you could try turning off hibernation in your current power plan to clear the file, rebooting and then re-enabling hibernation in the power plan to recreate the file and perhaps restore the hibernation settings. – John H Dec 1 '11 at 1:59

But I figured out what the problem was, and apparently it was nothing to do with my mucking around with the partitions. The problem was TrueCrypt.

When I run an encrypted system partition, things are fine (hibernation works). In fact this is a year-old feature of TrueCrypt.

But, oddly enough, hibernation doesn't work if I decrypt the drive (which I had done a couple days ago to fix my MBR).

Why does it fail on a non-encrypted C: drive? I don't know. A brief google on "TrueCrypt hibernation" did not reveal anything. Maybe I should look to see if there is a running TrueCrypt service and turn it off before attempting hibernation. I'll try that sometime, but not now.

In any case it's working again, and my system drive is encrypted, which is the way it needs to be.

  • Sorry my suggestions didn't work but I'm glad you found a solution. :) – John H Dec 1 '11 at 17:43
  • If TrueCrypt wasn't in the equation, I'm sure your suggestions would have worked. – 80skeys Dec 2 '11 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.