27

Suddenly, my Chrome language has been changed to Tamil. I didn't make this change manually. I don't know how to change this setting to English.

4 Answers 4

45

Oh the irony: trying to find the correct menu choices, when they're in a different language.
By way of an alternative, this address will bring up the language page:

chrome://settings/languages

If your preferred language is shown, simply drag it to the top and restart the browser. If it needs to be added, click the button at the bottom of the left pane.

4
  • 1
    Thanks, this was super helpful. My browser was in Chinese (which I can't read), but using the settings at this URL I was able to find "English (United States)" and add that and remove the other languages and then restart the browser.
    – Ryan
    Jul 16, 2013 at 19:01
  • 1
    Very nice and much more ubiquitous than all the other answers I've found so far. Thank you, sir!
    – Bruiser
    Dec 6, 2013 at 21:43
  • This answer is outdated. There is no such setting in that dialog box for me.
    – Calmarius
    Dec 22, 2016 at 8:54
  • 1
    My link was chrome://settings/languages
    – Klesun
    Jan 21, 2018 at 10:05
6

I got the answer from my friend. Here's how to change Chrome language.

Go to Settings » Advanced » Languages.

5
  • 2
    You can also bring this panel by typing "language" into the searchbox in the parameters. (or the translation if you are not in english) Sep 17, 2012 at 12:34
  • This answer is outdated. There is no such setting in that dialog box for me.
    – Calmarius
    Dec 22, 2016 at 8:54
  • Hello @Calmarius Actually this was an answer of Chrome which was available on 2011. For, which version of Chrome you're looking into it? Dec 22, 2016 at 8:58
  • @Praveen The current latest one. Actually after further googling I have found out that on Linux the interface language cannot be changed from this menu. It simply uses the system language settings and that's it. So I needed to change the system language to English to use chrome in English.
    – Calmarius
    Dec 22, 2016 at 9:06
  • I updated the answer with the latest Chrome settings, but I'm afraid that this really does not change the interface language. Please verify that.
    – slhck
    Aug 11, 2017 at 11:15
2

Probably http://www.google.com/support/chrome/bin/answer.py?answer=95416 will help?

Quoting the related stuff:

  1. Click the wrench icon on the browser toolbar.
  2. Select Options (Preferences on Mac and Linux).
  3. Click the Under the Hood tab and go to the "Web Content" section. Here are the various settings you can adjust:

Browser interface language

The browser interface language is used for browser menus and dialogs and it's based on the language you selected when you first downloaded Google Chrome.

In Windows, follow these steps to change this setting:

  1. Click Languages and spell-checker settings to open the "Language and Input" dialog.
  2. Select the language you'd like to use from the list. If the language isn't listed, first add it as one of your preferred webpage languages.
  3. On the right panel, click Display Google Chrome in this language.
  4. Restart the browser to apply the changes.

On a Mac, currently the browser interface language is determined by the Language & Text setting in System Preferences. To learn how to update your system language, visit Apple Computer’s Support .

On a Linux, check your system language support.

0

Search on Google for any random thing. A settings icon appears on the top right hand of the screen. Click it. Choose Languages in the left hand menu. Then choose your preferred language.

1
  • 2
    That changes the Google search language, but not Chrome's.
    – slhck
    May 4, 2013 at 19:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.