The drive is disconnected, and I'm off the network. How do I unmap the drive?

7 Answers 7


I can't test this here as I'm not on a network, but I think it's a case of doing this:

  1. Right-click Network in Windows Explorer.
  2. Select Disconnect network drive....
  3. In the list that appears, right-click the drive you wish to remove and select Remove.

I think it's something like that but as I say, I can't test it here.

  • What do I do if the drive does not show up in the Disconnect Network Drives window? Jan 29, 2022 at 7:43

On the command line (substitute your drive letter for z):

net use z: /delete
  • 4
    You don't even need to type in delete, you can get away with just del. Look at how much quicker you can disconnect!
    – Mitch
    Dec 1, 2011 at 19:30
  • 5
    This does not work with disconnected drives!
    – Tom
    Jun 17, 2013 at 15:28
  • 5
    This is much better than using the Windows Explorer approach if the drive isn't currently accessible. Even in Windows 8 you have to wait quite some time for the right-click context menu to appear for an unavailable mapping. With the command line approach it's immediate.
    – Bern
    Jun 28, 2013 at 8:26

On the command line, try:

net use

This shows all currently mapped drives. If the one you're looking for is in the list, you can use:

net use x: /delete

where X: is the drive you're trying to remove. But if the drive has been removed, there may be no such drive letter shown. In that case, just type the Remote identifier for the mapping:

net use\WorkFiles /delete
  • 1
    This worked perfect for me and covers all possibilities. This should be the correct answer!
    – Cagy79
    Aug 12, 2016 at 9:55

For the disconnected drive, for those who have SQL Server Management Studio in your pc, just run this query.

Exec master.dbo.xp_cmdshell 'net use x: /delete'

  • change the 'x' according to the drive name..
  • not sure if it will work with other database..
  • if your xp_cmdshell is not working or inactive, and this error occurs:

SQL Server blocked access to procedure 'sys.xp_cmdshell' of component 'xp_cmdshell' because this component is turned off as part of the security configuration for this server. A system administrator can enable the use of 'xp_cmdshell' by using sp_configure. For more information about enabling 'xp_cmdshell', see "Surface Area Configuration" in SQL Server Books Online.

Enable the xp_cmdshell by running this query:

-- To allow advanced options to be changed.
EXEC sp_configure 'show advanced options', 1
-- To update the currently configured value for advanced options.
-- To enable the feature.
EXEC sp_configure 'xp_cmdshell', 1
-- To update the currently configured value for this feature.

There is a more forceful way to get rid of dead links to mapped network drives.

You could delete the reference in your registry.

Just open "regedit.exe" and expand the key "HKEY_CURRENT_USER" and the key "Network". There you will see keys with letters that will represent the Mapped Drive Letters. When you delete a letter on "regedit.exe", the mapped drive letter will vanish on the next Windows restart cycle.


None of the above worked for me in Windows 10 for disconnected USB drives. What did work was:

  1. Right click on the Windows icon and select "Disk Management"
  2. Find the drive letter that is no longer used in the list of disks
  3. Right click on "Disk" and select "Change Drive Letter and Paths"
  4. Then select "Remove"
  • 1
    The question is about network drives rather than USB drives. Will this work for network drives when you are not connected to the network?
    – fixer1234
    Mar 11, 2017 at 19:57
  • 1
    Please read the question again carefully. Your answer does not answer the original question.
    – DavidPostill
    Mar 12, 2017 at 11:35

On Windows 7 you have to change the the automatically-connect-on-startup option to do not reconnect. I did this by remapping the drive identical to how it was, which then gave me the the checkbox for do not reconnect on startup. Restarted the machine and it was gone!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .