10

Every time I log on to my webmail I see a bar like on image below. I don't want to add this as an application and it is pretty annoying to close this every time. How can I disable it permanently?

The bar says this: example

EDIT:
I tried to use Firebug to see what causes this bar to appear but with no luck. Anyone help?

EDIT 2:

Su's answer from http://webmasters.stackexchange.com :

This is done by registering a protocol handler. From that page:

navigator.registerProtocolHandler("mailto", "https://www.example.com/?uri=%s", "Example Mail");

The site would just have to run a similar snippet at an appropriate moment(login, in your case).

Link: registering a protocol handler

How can this be blocked?

  • That sounds like something coming from your webmail. Have you tried looking in your webmail settings to see if you can disable it? – SaintWacko Dec 2 '11 at 17:21
  • I know that my webmail might send something to Firefox in order to display this. I want make Firefox ignore this. – Jan Ajan Dec 3 '11 at 9:42
  • 1
    I'm not having much luck figuring out how the webpage might request it. If you can find out, you might be able to block it using something like Ad-Block Plus. – SaintWacko Dec 5 '11 at 16:17
  • you could probably also write a Greasemonkey userscript that selectively overrides whatever Javascript functionality on the page that is trying to register itself as a mailto handler.. – merv Mar 3 '12 at 11:06
  • As some Firefox settings are OS-dependent, the answer may depend on your OS too. So can you specify your operating system and the Firefox version. – fiktor Sep 5 '12 at 8:52
2

have you tried going to about:config

There are some keys in there relating to mailto:

network.protocol-handler.external.mailto;true
network.protocol-handler.expose.mailto;false
network.protocol-handler.warn-external.mailto;false

You could try toggling them, I can't test as I can't recreate whats happening for you, I think maybe the first of the three to false maybe a good start,

Be careful when editing this config as it may cause strange things to happen maybe even break firefox.

| improve this answer | |
  • This recently just happened to me, after over 15 years of using it. Changing network.protocol-handler.external.mailto to false seems to have worked for me. – Asinine Sep 21 at 21:12
0

you can do it easily with adblock-plus addon for firefox (assuming you are polish you probably using it anyways :P ) or ad-block plus for chrome. And you get the nice advantage of all the ads blocked for you as well everywhere (even in youtube videos you no longer see commercials)

all you need to do is google search for ad block plus. download it install it

Who knows maybe its going to disappear as soon as you download the addon if not then find the name of the divider that the annoying popup appears I assume you know how to do that since you are familiar with firebug

then go to filter preferences ctr+shift+F

then go to custom filters tag then go to Element hiding rules (the last one) then click add filter then type #div(div_name)

div_name = the actual name of the div

and you are done. If something is an image and you want to block it you can right click it and there will be an option but im assuming this is not an image but a whole divider you want to get rid off.

| improve this answer | |
  • The topic starter has a message from Firefox (caused by a call to navigator.registerProtocolHandler). So, this message is not a part of a web-page and, thus, it's not that simple to block it with adblock. – fiktor Sep 5 '12 at 8:58
  • but the msg is insite a divider that always has the same name right? And you can just block this divider for that website. It shouldnt be a big problem... unless im missing something? – Xitcod13 Sep 5 '12 at 21:08
  • AFAIK Adblock works (i.e. can block) parts of the content of a web-page, but this message is shown by Firefox "above" the window with a web-page, i.e. it is not a part of the web page and, thus, can't be blocked with Adblock. – fiktor Sep 5 '12 at 21:18
0

… disable it permanently?

Mozilla bug 668577 - registerProtocolHandler notification should provide a "don't ask me again" button draws attention to How to hide/disable Firefox notification for addon/application | Firefox Support Forum | Mozilla Support (2011-06-30))

https://github.com/MrAlex94/Waterfox/issues/680#issuecomment-401004043 gives a (legacy) Stylish 2.1.1 workaround that's effective for:

Add Tutanota

Add o2 Poczta

For this case, you could try:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

/*
Adapted from https://support.mozilla.org/questions/994658#answer-556629 
for https://superuser.com/q/363827/84988
*/

notification[label^="Add o2 Poczta"][value="Protocol Registration: mailto"] {
  display: none !important; 
}

Firefox Quantum might require a different approach but the essence of the workaround should be the same; styling.

| improve this answer | |
0

Another little bad news, because Mozilla has made another change that's why now it didn't work with Firefox-v70.

As you can probably guess, apparently the file "userContent.css" can't rectify this trouble anymore... And no I wasn't able to find another solution even with the file "userChrome.css" But at least, it could be reactivate :

lockPref("toolkit.legacyUserProfileCustomizations.stylesheets",true);
## How to remove the button close on every tabs ?
## Just recopy this example inside the "userChrome.css"
@-moz-document url(chrome://browser/content/browser.xhtml)
{
    .tab-close-button {display:none !important;}
}

So thank you @0x7c0 because I had found this solution :

lockPref("network.protocol-handler.external.mailto",false);
## At this moment, the notification has vanished on the new website of Tutanota.
## Which can be reach only at this new adress : "https://mail.tutanota.com/login"
## That's right, now the previous adress : "https://app.tutanota.com/#login" doesn't seem to exist (at all).
## I will assume Tutanota has probably made the choice to remove it.

PS : For the record and for once reddit was hepful.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.