10

I would like to use both chinese keyboard and eclipse ctrl-space for suggestions popup. Since I use chinese very rare, I would like just to disable ctrl-space selecting this language.

I have removed this combination from windows' chinese keyboard setup, but it either returns (if I remove) or just works without setting (if chaged).

Hot to disable ctrl-space totally for keyboard?

2
  • The right answer here is probably not how to turn Ctrl-Space of but ask if there are an alternative keyboard sequence that could be used on chines keyboards that gives the same function in Eclipse. And there are, I just doesn't remember it now. :( I used to know it when I had chines students. – Anders Mar 7 '14 at 15:21
  • Use Alt-/ in Eclipse instead. – Anders Mar 7 '14 at 15:58
19

I've been aware of this Windows bug for years. After tons of unsatisfying workarounds and fruitless searching the one or two times a year I attempt to find a solution, I finally have it!

Procedure

  1. Go to Start > Type in regedit and start it
  2. Navigate to HKEY_CURRENT_USER/Control Panel/Input Method/Hot Keys
  3. Select the key named:
    • 00000070 for the Chinese (Traditional) IME - Ime/NonIme Toggle hotkey
    • 00000010 for the Chinese (Simplified) IME - Ime/NonIme Toggle hotkey
  4. In the right sub-window, there are three subkeys.
    • Key Modifiers designate Alt/Ctrl/Shift/etc and is set to Ctrl (02c00000).
    • Virtual Key designates the finishing key and is set to Space (20000000).
  5. Change the first byte in Key Modifiers from 02 to 00
  6. Change the first byte in Virtual Key from 20 to FF
  7. Log off and log back on. I don't think it's necessary to restart.
  8. Do not change the Hot keys for input languages in Control Panel, unless you want to do this all over again.

Notes: Symptoms

Each registry key (thing that looks like a folder) is for each specific hotkey setting that you would normally find in Control Panel > Region and Language > Keyboards and Languages > Change keyboards... > Advanced Key Settings > Hot keys for input languages. The recurring bug is the hotkey being automatically reset to Ctrl+space even if changed via the GUI.

This is for Windows 7 64-bit, though from my research, it looks like it may work for XP and Vista as well.

Sources:

Traditional Chinese Pocket IME Hot Key Registry Settings

Simplified Chinese MSPY 3.0 IME Hot Key Registry Settings

2
  • Hi, It is known that it is fixed in later windows e.g. Windows 10. but how to re-enable it ? I want Ctrl+space to be working in Windows 10 when the Chinese Lang is added. – Gokul E Jul 23 '18 at 7:27
  • @GokulE I'm on Win10 and still have this problem. – JiaChen ZENG Sep 25 '18 at 10:18
0

Hi I'm about to test this. I'm following this link

Step 1.
win+RregeditHKEY_CURRENT_USER/Control Panel/Input Method/Hot Keys
00000010 is for enable or disable the IME
00000011 is for toggle between full and half width characters
00000012 is for switch symbol mode

Step 2:
Go whichever hot key you want to modify, right click on the item and select modify, here are the rules:
Key Modifiers(ref):
00 C0 00 00, no Ctrl or Shift or Alt (Set this value if you don't need the hot key)
01 C0 00 00, leftAlt
02 C0 00 00, Shift 04 C0 00 00, Ctrl
06 C0 00 00, Ctrl+Shift
Or combination of the above to make your own.

Virtual Key code:
the actual key combination, ascii code
20 00 00 00, for Space
21 00 00 00, for PgUp
00 00 00 00, for no key
ff 00 00 00, for NONE (Set this value if you don't need the hot key)

Target IME:
leave it as it is, or change it to 00 00 00 00, for all languages( I suppose).

Reference Page

2
  • Tested. It works. – songyy Aug 25 '12 at 3:23
  • At the moment, this post is essentially only a link. To make sure the answer remains useful even if the link breaks, please edit it to include the relevant information. (Your answer was discovered in an effort to repair or remove old link-only answers.) – Ben N Jan 10 '16 at 5:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.