I was trying out the antivirus program Avast and I ran the boot time scan feature, where it scans your computer during the boot process, before viruses have a chance to initialize. A couple of files came up as corrupted, and so I deleted them.

When my computer booted up, all the services were disabled (as a result of this, the taskbar looks like the old Win98 gray task bar). So I'm assuming I deleted something important, which doesn't make sense if the files I deleted were corrupted (the OS couldn't use them anyway). So I thought I'd run a system restore, but the service for that was disabled, so I enabled the Volume Shadow Copy service (if I had to enable something else too, let me know).

I ran System Restore again and this time I didn't get the disabled service error, but now it tells me that no restore points have been created, which doesn't make sense because Windows should make them regularly. So I can't restore to the working state either... It might be possible that Avast thought the system restore files were corrupt and that's what I deleted, that's just a theory.

I'm running the system file checker with the command sfc /scannnow to see if there's a corrupted file problem.

Any help to fixing the problem or restoring my computer to it's previous state would be helpful. My computer is running Windows 7.

For now, I can simply re-enable all services, but I'd prefer restoring to the previous state, as I'm positive something else must have been wrong to have caused this problem, and enabling all services (including ones that weren't enabled before) leads to slow boot and run times.

sfc didn't find any problems.

  • If you solved your problem, please use the answer your question button below and supply your answer there. You can then accept it in two days and even get reputation for it! – slhck Dec 2 '11 at 19:48

It turns out the reason System Restore wasn't seeing any restore points was because not all of the necessary services were enabled. I don't know which ones needed to be enabled, but I enabled all of my services through msconfig and tried again and it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.